Issue when "Hide from Exchange address lists"

I have added a 2nd email to domain to our exchange. However, this email must be seperate from from our regular email.
Lets use me.  Grady@domain1.com and Grady@domain2.com  I will be hiding grady@domain2.com as to not confuse internal users from sending to my incorrect account.
That all works great.
My issue is when I send from Grady@domain2.com the recieved email shows the LDAP path and not my return address. When I unhide it it works fine.
I need to keep my 2nd domain hidden from Exchagne GALS and be able to send as normal.
Grady-VogtAsked:
Who is Participating?
 
MesthaConnect With a Mentor Commented:
Your options are

don't hide items
remove the rollup
call microsoft

Simon.
0
 
jawad1481Commented:
HI!

I believe we have a provision to select which should be your Primary SMTP address and Secondary SMTP address.

Try selecting the email addresses. let me know if you still face the problem.
0
 
Grady-VogtAuthor Commented:
In the users email addresses I have removed domain1.com and set replay to domain2.com No other email addres's exist.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Are you trying to send as user@domain2.com? What's the real outcome you need?
0
 
Grady-VogtAuthor Commented:
Yes, I logon as user@domain2.com to OWA.  I can send and recieve as user@domain2.com However, this account user@domain2.com needs to be hidden from the GAL for company reasons.  As a result of hiding it the reply address is NOT being sent. Instead it shows the "DN" behind the name on the recipients email.  here is what they get..
"<IMCEAEX-_O=PBS_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=user@domain1.com>"

They get "User@domain2.com" when it is not hidden.
0
 
jawad1481Commented:
HI!

I am sure this is related to X500, you will need add X500.

Thanks.

Jawad
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Don't use two accounts and hide one.

Just add user@domain2.com as the primary smtp server of user@domain1.com. So, one ad account and mailbox for user1. But, set his primary smtp as user1@domain2.com
Add user1@domain1.com as an alias if you want both.

Rajith.
0
 
Grady-VogtAuthor Commented:
I must have 2 accounts as the email between the account must stay seperate.  
Exchaegn 2007 does not use X500 so how would that resolve it?
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
In that case, give user1 full access to user1@domain2.com mailbox and add it as an additional mailbox in Outlook. Once it is added, hide the account from exchange address list.
0
 
MesthaCommented:
Is this Exchange 2007?
If so then it is a change in the behaviour of Exchange with hidden accounts that was introduced in the last rollup. It will be fixed in the next rollup. In the meantime you can either remove rollup 7 or call Microsoft for the fix.

Simon.
0
 
Grady-VogtAuthor Commented:
Yes, it IS exchange 2007.. So this is a known issue?
0
 
MesthaCommented:
0
 
Grady-VogtAuthor Commented:
I will patch the server tonight and let you konw if it resolves it.. I think it should!
0
 
Grady-VogtAuthor Commented:
OK, Well, I looked and I have this already installed... Now what?
0
 
Grady-VogtAuthor Commented:
Ok, I did not read it correctly.. This issue is only IF I have rollup 7 installed and I do.. So my options are dont hide it and wait tuntil the rollup for SP1 comes out..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.