Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cannot FTP to SCO OpenServer 5 using Internet Explorer 7

Posted on 2009-05-01
12
Medium Priority
?
529 Views
Last Modified: 2013-12-08
I am able to access my sco server ftp site using IE6 with no problem.  After I upgraded one of my machines to IE7, I can no longer access it.  The browser throws a "internet explorer cannot display web page" error.  I can switch to another machine running IE6 and still acces it.  I can access it from the IE7 machine if I use windows explorer and type the FTP addres in the address bar.  I have no problem accessing my windows 2003 server ftp site with either IE6 or IE7.  I'm guessing it's some security setting in IE7 but I've yet to figure out what it is.  Both my IE6 machine and IE7 machine are Windows 2003 servers.  Any ideas?
0
Comment
Question by:nicklucas
12 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 24281585
do you have a firewall between the two systems? make sure that both ports 20 and 21 are allowed
0
 
LVL 5

Expert Comment

by:yronnen
ID: 24288435
Go to the Internet Options settings and choose the "advanced" tab. One of the settings is for the ftp passive mode. Try to change this setting (usefull for firewalls etc.).
0
 

Author Comment

by:nicklucas
ID: 24337755
There is no firewall set between the two servers.  I checked the ftp passive option and it was already selected.  I toggeled if off and tested, then back on again and tested just for good measure, but that didn't work.
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
LVL 14

Expert Comment

by:mikelfritz
ID: 24341697
Maybe add the SCO server to the "Trusted server" section in IE7?
0
 

Author Comment

by:nicklucas
ID: 24356935
It tells me you can only add https:// sites to the trusted server section in IE 7.
0
 
LVL 14

Expert Comment

by:mikelfritz
ID: 24357233
There should be a checkbox for require server verification - uncheck it.
0
 

Author Comment

by:nicklucas
ID: 24357542
ok.  I was able to add the ftp site, but it still doesn't let me access it.
0
 
LVL 14

Accepted Solution

by:
mikelfritz earned 2000 total points
ID: 24363633
Some info here:

http://support.microsoft.com/kb/941896

Not sure if the regedit would work for you.  

From the KB:
Versions of Internet Explorer that are earlier than Internet Explorer 7 are not separate from the rest of Windows. Internet Explorer and the rest of Windows just have different entry points in the user interface. When you browse an FTP site in Internet Explorer, the FTP site opens in Windows Explorer. Windows supports home directories and the relative path of the FTP URL. Therefore, after you enter the user name and the password, you are redirected to an assigned folder according to the user name. This assigned folder appears as the root of the FTP server.

Internet Explorer 7 is separate from the rest of Windows. Therefore, when you use Internet Explorer 7 to access an FTP site, the behavior differs from the behavior of earlier versions of Internet Explorer. Internet Explorer does not support home directories and the relative path of the FTP URL. Therefore, you are redirected to the root folder of the FTP server. If you do not have permission to access the root folder, you cannot access the FTP site.
0
 

Author Comment

by:nicklucas
ID: 24364028
I think I figured it out, in part becuase of the last response.

Using IEv6, I always received an FTP folder error which mentioned something about folder permission.  I was then able to use File->Login as... to put in the root credentials and access the ftp site.  Using IEv7, I was told the site was unaccessable.  File->Login as... was not an option.

I tried accessing the site in the following way;  ftp://root@192.168.10.1. What this does is sends a username (rather than the assumed "anonymous" user I'm guessing) to attempt the initial logon to the site.  This then popped up a window that allowed me to put in the root password for the SCO server.  I was then able to access the ftp site.  Why when sending no username doesn't allow the File->Login as... anymore I'm not sure, but this is a way to get it working.

Thanks to everyone for the help.
0
 

Author Closing Comment

by:nicklucas
ID: 31576926
Thank you.  Got me pointed in the right direction!
0
 

Author Comment

by:nicklucas
ID: 24364117
FYI...   The registry key mentioned in http://support.microsoft.com/kb/941896 did not exist on my IEv7 server and the IE advanced tab option it mentions was already checked so neither of those two helped me out.  Confirming it was a folder permission problem, helped me recall the way to send the username along with the ftp url for this workaround.
0
 
LVL 14

Expert Comment

by:mikelfritz
ID: 24364900
It sounds like it's because IE7 is not as linked into the OS (antitrust stuff?) and that login thing was linked to windows explorer.

Mike
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question