Cannot FTP to SCO OpenServer 5 using Internet Explorer 7

I am able to access my sco server ftp site using IE6 with no problem.  After I upgraded one of my machines to IE7, I can no longer access it.  The browser throws a "internet explorer cannot display web page" error.  I can switch to another machine running IE6 and still acces it.  I can access it from the IE7 machine if I use windows explorer and type the FTP addres in the address bar.  I have no problem accessing my windows 2003 server ftp site with either IE6 or IE7.  I'm guessing it's some security setting in IE7 but I've yet to figure out what it is.  Both my IE6 machine and IE7 machine are Windows 2003 servers.  Any ideas?
Nick LucasIT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

omarfaridCommented:
do you have a firewall between the two systems? make sure that both ports 20 and 21 are allowed
yronnenCommented:
Go to the Internet Options settings and choose the "advanced" tab. One of the settings is for the ftp passive mode. Try to change this setting (usefull for firewalls etc.).
Nick LucasIT ManagerAuthor Commented:
There is no firewall set between the two servers.  I checked the ftp passive option and it was already selected.  I toggeled if off and tested, then back on again and tested just for good measure, but that didn't work.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

mikelfritzCommented:
Maybe add the SCO server to the "Trusted server" section in IE7?
Nick LucasIT ManagerAuthor Commented:
It tells me you can only add https:// sites to the trusted server section in IE 7.
mikelfritzCommented:
There should be a checkbox for require server verification - uncheck it.
Nick LucasIT ManagerAuthor Commented:
ok.  I was able to add the ftp site, but it still doesn't let me access it.
mikelfritzCommented:
Some info here:

http://support.microsoft.com/kb/941896

Not sure if the regedit would work for you.  

From the KB:
Versions of Internet Explorer that are earlier than Internet Explorer 7 are not separate from the rest of Windows. Internet Explorer and the rest of Windows just have different entry points in the user interface. When you browse an FTP site in Internet Explorer, the FTP site opens in Windows Explorer. Windows supports home directories and the relative path of the FTP URL. Therefore, after you enter the user name and the password, you are redirected to an assigned folder according to the user name. This assigned folder appears as the root of the FTP server.

Internet Explorer 7 is separate from the rest of Windows. Therefore, when you use Internet Explorer 7 to access an FTP site, the behavior differs from the behavior of earlier versions of Internet Explorer. Internet Explorer does not support home directories and the relative path of the FTP URL. Therefore, you are redirected to the root folder of the FTP server. If you do not have permission to access the root folder, you cannot access the FTP site.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nick LucasIT ManagerAuthor Commented:
I think I figured it out, in part becuase of the last response.

Using IEv6, I always received an FTP folder error which mentioned something about folder permission.  I was then able to use File->Login as... to put in the root credentials and access the ftp site.  Using IEv7, I was told the site was unaccessable.  File->Login as... was not an option.

I tried accessing the site in the following way;  ftp://root@192.168.10.1. What this does is sends a username (rather than the assumed "anonymous" user I'm guessing) to attempt the initial logon to the site.  This then popped up a window that allowed me to put in the root password for the SCO server.  I was then able to access the ftp site.  Why when sending no username doesn't allow the File->Login as... anymore I'm not sure, but this is a way to get it working.

Thanks to everyone for the help.
Nick LucasIT ManagerAuthor Commented:
Thank you.  Got me pointed in the right direction!
Nick LucasIT ManagerAuthor Commented:
FYI...   The registry key mentioned in http://support.microsoft.com/kb/941896 did not exist on my IEv7 server and the IE advanced tab option it mentions was already checked so neither of those two helped me out.  Confirming it was a folder permission problem, helped me recall the way to send the username along with the ftp url for this workaround.
mikelfritzCommented:
It sounds like it's because IE7 is not as linked into the OS (antitrust stuff?) and that login thing was linked to windows explorer.

Mike
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.