• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 922
  • Last Modified:

How to fix Ubuntu Splash Screen 9.04?

Hello everybody!

I recently installed Ubuntu Jaunty.  Things are running fine but when I first installed it there were some graphic card issues that I later fixed.

Now when it is booting up and showing the splash screen, it only shows it until about 30% loaded, then it shows the actual prompt commands while the operating system loads.  Anybody know what caused it to stop showing the splash screen the whole way through the OS load process?
0
parlays
Asked:
parlays
1 Solution
 
Fabio MarzoccaFreelancerCommented:
Open from root the file /boot/grub/menu.lst and remove all occurencies of the word "quiet". Then reboot and look at the last message before screen switches to terminal, so that you can investigate on which process is causing the problem.
0
 
ai_ja_naiCommented:
what is the lowest messange showing up on the bottom of the screen when the splash screen screws?
0
 
parlaysAuthor Commented:
Sweet, thanks I'll try that on tuesday when I get back to my desktop.... maybe I'll drive there today to see what's going on, I'll let you know as soon as I find out.  Appreciate the help fellas!!
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
torimarCommented:
I had the exact same problem after my Ubuntu (and other Linux distros) had become unbootable and I had to repair Grub.
In my case it was clear that the drive identifiers (UUIDs) had been messed up somehow, and it turned out that a missing UUID of my swap partition had caused this behaviour. The repair was easy enough.

Just to make sure that a similar issue may be the cause of your problem, run the following commands in a terminal:
sudo blkid
cat /etc/initramfs-tools/conf.d/resume
cat /etc/fstab

Comparing the results of the first command and the two other ones, do you get different number codes for the Swap partition? Or even none at all?

In that case, here's the easy way to solve this:
-- sudo fdisk -l (that is a small "L")
-- write down the device name of your swap partition (sdxx)
-- sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.repair
-- gksudo gedit /boot/grub/menu.lst
-- browse down to your main Ubuntu start menu entry (it will most likely be the first one in the list; in any case, it's the one with the highest kernel number)
-- in the "kernel" line, behind "root=/dev/....." insert "resume=/dev/sdxx", replacing sdxx by the device name of your swap partition
-- save, exit and reboot.


There is also a more complicated solution which recreates the swap UUID described here: http://ubuntuforums.org/showpost.php?p=6439174&postcount=12
0
 
torimarCommented:
Hi parlays,

so what happened on that tiesday? Any news on the issue?

As I said, I had the exact same problem, and it's solved now - by using the "easy way" that I described above.
0
 
parlaysAuthor Commented:
Thanks guys, I'm going to try it out now, and then I'll accept the solution.  Appreciate your help.
0
 
torimarCommented:
The other participating experts posted a question and a recommendation on first steps for troubleshooting; in ID:24302511 I posted an explanation of the issue (Grub menu containing an unidentifiable swap drive) and a step-by-step solution which is proven to have worked in an identical case (Ubuntu boot screen disappearing halfway through the boot process).

Hence I recommend my comment ID:24302511 to be accepted as the solution.

0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now