?
Solved

boot system flash not working

Posted on 2009-05-01
7
Medium Priority
?
3,114 Views
Last Modified: 2012-05-06
I am trying to upgrade my IOS on a Cisco Catalyst 2960 swtich.

I uploaded the new IOS to the flash directory via tftp, and can confirm via a "dir" command that it does reside there.

When I enter config mode and run the command:

boot system flash c2960-lanbasek9-mz.122-50.SE1.bin

it says invalid input character at ^ c

I tried

boot system flash:c2960-lanbasek9-mz.122-50.SE1.bin

and that did not throw an error, but after reload it still loads the old IOS.
0
Comment
Question by:Tercestisi
  • 4
  • 3
7 Comments
 
LVL 3

Accepted Solution

by:
ccsistaff earned 2000 total points
ID: 24284866
Run

show flash

to see if both the old and new image are present on the flash card.  If they are, copy the old image to your tftp location and then delete it with

delete <old_flash_image.bin>

Reload the switch and it should boot the new image by default.  
0
 

Author Comment

by:Tercestisi
ID: 24284877
The current (not new) flash image is in a directory flash:c2960-lanbase-mz.122-35.SE5

I can cd to the directory to see the actual .bin, but do not know the command to transfer this (since it is in the directory) to my tftp location.

I have tried:

copy flash:2960-lanbase-mz.122-35.SE5/2960-lanbase-mz.122-35.SE5.bin tftp://192.168.1.145

copy flash:2960-lanbase-mz.122-35.SE5.bin tftp://192.168.1.145

copy 2960-lanbase-mz.122-35.SE5.bin tftp://192.168.1.145

but it can never find the file.
0
 
LVL 3

Expert Comment

by:ccsistaff
ID: 24284892
try changing directory to the image first and then copy.

cd 2960-lanbase-mz.122-35.SE5
copy 2960-lanbase-mz.122.35.SE5.bin tftp

verify that the filename is correct also.  zeros and 'S' often times look like 'O' and fives.  
0
Get Certified for a Job in Cybersecurity

Want an exciting career in an emerging field? Earn your MS in Cybersecurity and get certified in ethical hacking or computer forensic investigation. WGU’s MSCSIA degree program was designed to meet the most recent U.S. Department of Homeland Security (DHS) and NSA guidelines.  

 

Author Comment

by:Tercestisi
ID: 24284918
That worked; thanks.

My question is why it it wasn't respecting my boot system flash: command originally?
0
 
LVL 3

Expert Comment

by:ccsistaff
ID: 24284946
Was the image at the root of your flash card as indicated by your command or is it located in a directory?  

boot system flash:c2960-lanbasek9-mz.122-50.SE1.bin

Did you save the running config after setting the boot flash command?  
0
 

Author Comment

by:Tercestisi
ID: 24286122
The image was on the root of the flash card; I tried both ways (saving running config and not).
0
 
LVL 3

Expert Comment

by:ccsistaff
ID: 24286503
It doesn't look like you were doing anything wrong so I'm at a loss to explain why it didn't work.  I'm sorry I couldn't be more helpful on that point.
0

Featured Post

Rewarding opportunities for women in IT

Across the nation, technology jobs are vacant because there aren’t enough qualified professionals to fill them. With a degree from WGU, you can get the credentials it takes to become an in-demand IT professional. Plus, WGU’s IT programs include industry certifications.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
Let’s face it: one of the reasons your organization chose a SaaS solution (whether Microsoft Dynamics 365, Netsuite or SAP) is that it is subscription-based. The upkeep is done. Or so you think.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question