• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 917
  • Last Modified:

Add a virtual host to WAMP I get a 403

I am trying to add a Virtual host to my local development envoirment so that I can have changes to the code tested from my workspace.

I followed the instrutions in here
http://jagztalk.com/multiple-virtual-hosts-on-wampserver.html

Essentially I did the following ....

1.I added the following to the http.conf
<VirtualHost 127.0.0.10>
    ServerAdmin your@email.com
    DocumentRoot C:/hourville/myfiles/
    ServerName yourdomain.local
    ErrorLog C:/wamp/bin/apache/Apache2.2.11/logs/error.log
    TransferLog C:/wamp/bin/apache/Apache2.2.11/logs/access.log
</VirtualHost>
2.
Then added the follwing in the hosts files at  
C:\WINDOWS\system32\drivers\etc

127.0.0.10      yourdomain.local

3.Tried to access it by
http://yourdomain.local/

I get a 403 ...
0
micro_learner
Asked:
micro_learner
1 Solution
 
thehagmanCommented:
Why 127.0.0.10? Don't you want 127.0.0.1?
Or try *
0
 
Sudaraka WijesingheWeb Application ProgrammerCommented:
Do you have directory index file and settings configured correctly?

i.e
DirectoryIndex index.htm
and place index.htm in C:\hourville\myfiles
0
 
RoonaanCommented:
Have you also added a
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
IanThCommented:
does it work if you use the ip address
0
 
RoonaanCommented:
403 means forbidden. So apache knows where to find the files, it only will not host the files because you have probably not the right allow from/deny from settings on the virtual host directory. So you probably have to add

<Directory "C:/hourville/myfiles/">
  Order allow,deny
  Allow from all
</Directory>
0
 
yfastudCommented:
you need to make some changes

1. change to ip for vh from <VirtualHost 127.0.0.10> to <VirtualHost *:80> w/ 80 is default web server port and also make sure to add exception for that port in all firewalls/antivirus; check here for idea
http://guides.jlbn.net/setaccess/setaccess2.html

2. make sure to have folder logs in folder C:/wamp/bin/apache/Apache2.2.11

3. if your web folder is outside your main document root which already configured in main config file, you need to add exception as Roonaan pointed out

Actually, if using wampserver, you should follow my guide here
http://blog.jlbn.net/?p=23
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now