Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Setting up VLAN's on Cisco Catalyst 2960

Posted on 2009-05-02
5
Medium Priority
?
1,801 Views
Last Modified: 2012-05-06
I will be tying in roughly 18 VLAN's from a trunk into this switch. The VLAN's were originally created on another Catalyst that is ISP owned and is used as a demarc point.

In their documentation they have:

Gi0/1: trunk uplink
Gi0/2: trunk downlink
Fa0/1-18 VLAN 700-717

When I use the CNA, all my interfaces are labled as Gi0/X so I am confused as to what the Fa0/X refers to?  I need to set up a dot1q trunk from that switch to our switch, and then another trunk from our switch to the ASA we have for a router-on-a-stick purposes.

What commands would be necessary to set this up? Note that VLAN 700 is the management VLAN.
0
Comment
Question by:Tercestisi
  • 3
5 Comments
 

Author Comment

by:Tercestisi
ID: 24286343
Duh... Gigabit and Fast... just realized that.

I have a side question... if they create their downlink trunk on a specific interface, do I need to create my trunk on the same interface on my switch, or can I do so on any interface?

I'm still interested in comparing the commands I have vs. anothers.
0
 

Author Comment

by:Tercestisi
ID: 24286804
Here's my config so far.

I am waiting to hear back from the ISP on what they set as their native VLAN.

Current configuration : 7252 bytes
!
! NVRAM config last updated at 12:14:55 CST Sat May 2 2009
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname corp-switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$FI3p$lnnsgRcISzOPPPVvMHe9V.
!
no aaa new-model
clock timezone CST -6
system mtu routing 1500
vtp mode transparent
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 400
 name MGMT
!
vlan 401
 name CORP-MAIN-O
!
vlan 402
 name E-O
!
vlan 403
 name P1-O
!
vlan 404
 name P2-O
!
vlan 405
 name P3-O
!
vlan 406
 name P4-O
!
vlan 407
 name S5-O
!
vlan 408
 name L1-O
!
vlan 409
 name L2-O
!
vlan 410
 name S8-O
!
vlan 501
 name MAIN-B
!
vlan 502
 name E-B
!
vlan 503
 name P1-B
!
vlan 504
 name P2-B
!
vlan 505
 name P3-B
!
vlan 506
 name S4-B
!
vlan 507
 name S5-B
!
vlan 508
 name L1-B
!
vlan 509
 name L2-B
!
vlan 510
 name S8-B
!
!
!
interface GigabitEthernet0/1
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/2
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/3
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/4
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/5
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/6
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/7
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/8
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/9
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/10
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/11
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/12
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/13
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/14
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/15
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/16
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/17
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/18
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/19
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/20
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/21
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/22
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/23
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/24
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/25
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/26
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/27
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/28
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/29
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/30
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/31
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/32
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/33
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/34
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/35
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/36
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/37
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/38
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/39
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/40
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/41
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/42
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/43
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/44
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
 switchport voice vlan untagged
!
interface GigabitEthernet0/45
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport mode access
!
interface GigabitEthernet0/46
 description trunk uplink
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport trunk allowed vlan 400-510
 switchport mode trunk
!
interface GigabitEthernet0/47
 description trunk downlink
 switchport access vlan 401
 switchport trunk native vlan 401
 switchport trunk allowed vlan 400-510
 switchport mode trunk
!
interface GigabitEthernet0/48
 description Management
 switchport access vlan 400
 switchport trunk native vlan 401
 switchport mode access
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan400
 ip address 192.168.1.216 255.255.255.0
 no ip route-cache
!
interface Vlan401
 no ip address
 no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Open in new window

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 24287153
>if they create their downlink trunk on a specific interface, do I need to create my trunk on the same interface on my switch, or can I do so on any interface?

You can connect it to any interface on your switch.

As for the configuration, all you need to know is the speed, duplex, trunking protocol and (if 802.1q) the native VLAN.

On your config, you've got a lot of commands that are unnecessary. They aren't hurting anything, they just have no function.

For example:
 switchport trunk native vlan 401
 switchport mode access

There is no need for the "switchport trunk native vlan 401" command. That's only if the port is a trunk.

Finally, while it can't be decrypted, it's not a good idea to include the privileged mode password when you post a config. While a brute force crack is unlikely, it is possible.
0
 

Author Comment

by:Tercestisi
ID: 24287197
Thanks; I still need to confirm the speed and duplex from the ISP.

I did remove those unnecessary commands previously after I saw them when posting; thanks.

I also modified the privileged mode password before posting by switching a few of the characters.

0
 

Expert Comment

by:hayesie
ID: 33040830
You should just encrypt your passwords then no one can see them.
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question