• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 303
  • Last Modified:

How do I get out of the ASP.Net environment?

I'm not sure I even know how to ask this question. For the past two years I've been developing websites on my Windows XP PC. I develop in either ColdFusion or PHP. I've been running IIS and ColdFusion app server. Everything working fine.

In Dreamweaver, if I'm developing in PHP or in ColdFusion, I can preview in browser by hitting F12.

This past week, I was doing a proof-of-concept for a client, with the help of a vendor, and their software runs on the ASP.NET platform. We installed all the necessary "stuff" on my pc and ran the vendor's software.

Now I'm back to doing my own development again and now when I try to preview in browser in Dreamweaver, it doesn't work. If I'm trying to preview a PHP page, Firefox asks me if I want to save or open. If I'm tyring to preview a Coldfusion page, Firefox displays an error: "Server Error in '/JrunScripts' Applicaton. The resource cannot be found. HTTP 404 .. ." etc. The requested URL was "/JRunScripts/jrun.dll/index.cfm". And at the end of the error, there is "version information" that says "Microsoft .NET Framework Version 2.0.50727.3053; ASP.NET Version:2.0.50727.3053."

So I think that somehow my pc is trying to run the .NET framework? And so can't interpret the PHP or ColdFusion pages?

How do I "undo" this and get back to my normal environment? Unfortunately, the vendor isn't available since it's the weekend!

I've looked at the list of services that are started and nothing looks amiss there. I have IIS and my ColdFusion App Server running. There are two service with .NET in the name but neither of them is started: ".NET Runtime Optimization Service v2.0.50727_X86" and "ASP.NET State Service".

So I'm wondering if there is some configuration in IIS that maybe the vendor did that I didn't see?

I don't know anything about .NET and I don't know a whole lot about IIS, other than that I run it, and I change the home directory for the default web site depending upon which local site I'm working on.

HELP!!!

0
alicia1234
Asked:
alicia1234
  • 2
  • 2
1 Solution
 
Steve BinkCommented:
It sounds like the .NET installation displaced CF in IIS.  I'm not much on CF, but from what I remember it installs pretty thoroughly into IIS through the ISAPI filters.  .NET does the same, and may have an impact on some of CF's settings.

Try reinstalling CF.  Getting PHP to work outside of CF is a trivial exercise, but I think your overall problem is with CF being broken.
0
 
alicia1234Author Commented:
Sorry for the delay: I had posted this question on 5/2 with 500 pts because I had a deadline and needed an answer fast.

When I didn't have any answer in 24 hours, I decided to just uninstall everything that had been installed with the vendor's app - so that was the vendor's app, plus MSSQL, Visual Web Developer and a whole host of other things that all of those brought in.

After I'd gotten rid of all of those programs, my local testing environment worked again just fine for both ColdFusion and PHP.

So - I'd like to ask for a points refund on this.
0
 
Steve BinkCommented:
In other words, you used the procedure I recommended, but believe the points should be awarded because the answer was not provided fast enough?
0
 
alicia1234Author Commented:
I'm sorry - I really don't mean to slight anyone.

I solved the problem by uninstalling the vendor software and other associated software that came in with it. I did this before I saw routinet's post - because, as I said, it was a timely issue. Routinet's post said to reinstall CF - I did not do that. I uninstalled the vendor's software.

Perhaps I erred by not saying specifically that I had assigned high points because it was a timely issue.

So to award points and say that re-installing CF was the solution would not be correct, because, in my case, that was not the solution. In all fairness, I can't say that it WASN'T the solution - it's just that I didn't do it because I had already solved my problem before routinet's post. If I weren't so under the gun, I would have come back to this question and deleted it before anyone responded, because I had already found a solution before routinet's post.

So I'll leave this to the moderator to decide.

routinet - I'm sorry you are offended.

 
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now