Exchange 2003 (ESEUTIL) Defrag Not Working

I have been cleaning up an Exchange 2003 Server, deleting mailboxes, for the last two weeks. Last week I ran the ESEUTIL on an Exchange 2003 priv1.edb with no problem.   Today, I tried it again, and received the following error message; when trying to run ESEUTIL:

Error: Access to source database '\\mailserver\z:\exchsrvr\mdbdata\priv1.edb /td:\
Exchange\Temp.edb' failed with Jet error -1022.
Operation terminated with error -1022 (JET_errDiskIO, Disk IO error) after 0.16

Microsoft's web-site has a link showing the most common error messages; unfortunately this being not one of them.  Has anyone ever seen this particular error message, know the link to the fix, or know how to resolve?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I don't think \\mailserver\z: is a valid unc... I would expect something like \\mailserver\z$\exchsrvr\mdbdata\priv1.edb or \\mailserver\exchsrvr\mdbdata\priv1.edb
Please tell us what is the exact command you are using for ESEUTIL. As mentioned \\mailserver\z: is not a valid path.
Please refer:
Let me know
Nitin Gupta (gupnit)
rckollarAuthor Commented:
\\mailserver\z$\exchsrvr\mdbdata\priv1.edb  the UNC that I used.  Not sure why $ showed up.  Must be a typo.
Hi! rckollar,

I believe you dont have sufficient space on the drive where you are running defrag.

you must have atleast 110 % free space on the drive where you are running the defrag.


The problem is with the Syntax which you are using. could you please write the complete Syntax without any typo.




Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.