Eseutil /d errpr - Unable to find the callback library jcb.dll or one of it's dependancies

Okay, I'm attempting to resolve an issue where Exchange Server 2003 has reached it's maximum of 16Gig.  The system has gone down.  I've run Exeutil /p to resolve any problems in the datastore, it has reported no problems.  Then I've run Eseutil /d to attempt to both defrag the store and reduce it's size.

At approximately 10% of the Defrag operation it fails reporting "Unable to find the callback library jcb.dll..."

Here is the situation.
* This is Exchange 2003 Standard
* The OS is Server 2003
* Exchange is not installed in the default location.  It is installed in F:\Exchange.  Therefore the jcb.dll would be in F:\Exchange\Bin
* jcb.dll is present in F:\Exchange\Bin.

I've added F:\Exchange\Bin to the System Path as prescribed by another post regarding this and for an extra precaution rebooted the Server.

I still get the error in question at the same point of the Defrag.

If Jcb.dll is corrupted is there anyplace where I can download a "clean" copy?

What else am I missing?

I have attempted to regsrv32 the dll but received an error something to the effect of could not find the startpoint...
GilSimonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jawad1481Commented:
HI!

Could you please tell me how much RAM do you have on your server? If its more than 1GB than oepn boot.ini and add switch  /3GB /USERVA  --> save the boot.ini file and reboot the server.

Now try to run Defrag and you wont get error message.

Cheers.
Jawad.
jawad1481Commented:
Hi!

Are you still facing the same issue ?

Let me know if you need any help.

Thanks.

Jawad.
GilSimonAuthor Commented:
Yes, we are facing the same issue.

We've added the /3G and rebooted.

There is 4 Gig of RAM.

We have a communication going with Microsoft regarding the issue.

We are currently installing SP2 and will make the Registry Mod to increase the size of the Store.

I will post the solution that works unless anyone has something to add.

Thanks
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

jawad1481Commented:
Hi!

If you have added /3GB /USERVA switch you wont be facing the issue.

i repeat for exapmple if this is your boot.ini file ......................................./fast detect /3GB /USERVA

save this and reboot the server.

if you ahve planned to increase the limit by registry modification than upgrade to service pack 2.

open regedit --> HKLM\SYSTEM\CURRENT CONTROLSET\SERVICES\MSExchangeIS\PARAMETERSSYSTEM\SERVER NAME\PRIVATE<long guid> \
DWORD =  Database Size Limit in GB
VAlue = 70 GB.

Similarly for Public <long guid>
DWORD =  Database Size Limit in GB
VAlue = 70 GB.


Cheers.

Jawad.
GilSimonAuthor Commented:
We've been in contact with Microsoft Tech Support and have solved the problem.  I've been pulled off it for other issues and my partner has been working on the issue.  Tomorrow I will talk with him and get the full resolution for posting.

Thank you for your assistance Jawad.  If our resolution matches yours I will award these points to you, it does look that way though.
smalloyCommented:
Gill, please do post the solution that you have. I am in the exact same spot and at my whits end.My difference being that the databases (EDB and STM) are on a NAS server with a iSCSI connector so the system sees the connection as a local drive. I can not imagine this has anything to do with the issue.

Thanks,
Steve
smalloyCommented:
Just found this, will test tomorrow and see if it works, it makes sense.


Add the c:\program files\exchsrvr\bin directory to your path environmental variable, heres how:

-> Right-mouse click my computer,
-> Advanced Tab,
-> Environmental Variables button,
->  double-click on the Path entry in the bottom window, add this to the end of the string:
;c:\program files\exchsrvr\bin
smalloyCommented:
Also - Its not my idea, it came from this EE post:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23367294.html

I noted that the other person having this issue wrote:
"Worked like a charm.  Pretty frustrating when the Microsoft KB is totaly lacking in any detail or otherwise helpful. "

I will test this tomorrow, Saturday EST, and post if this resolves the issue. We have a huge EDB so its likely going to take 26+ hurs to defrag.
smalloyCommented:
Unfortunately, it failed at the same place, 10% complete, with the same error message: Unable to find the callback library jcb.dll or one of it's dependencies. Fed up and out of options, calling Microsoft.
GilSimonAuthor Commented:
Smalloy

I've done the system variable addition.  That didn't help.

As a matter of fact the link that you posted was the first place I went.

I am talking with the tech that inherited the problem in the first place.  I was just assisting him for the day.

I will post as soon as I get the resolution from him.

Sorry it is taking so long.
GilSimonAuthor Commented:
I've just talked with the tech assigned the issue.

He said that:
1. Install SP2
2. Increase the size of the store in the Registry to 75 gig

It didn't resolve the problem with the defrag but it made it unnecessary (his words not mine).

Increasing the size of the store can be found at http://support.microsoft.com/kb/912375.

Though I know that this doesn't resolve the "could not find callback..." issue you may want to do this to see if it makes your datastore mount.  It did, however, cause the error to occur later in the defrag process (I know, big deal!).

Other things you may want to look into.

eseutil /mh to find out if the datastore was shut down properly

If you can mount after the SP2 and reg hack then try the isinteg utility.  That may clear up some corruption in your store.

If there are any other developments I will post them.
smalloyCommented:
Thank you for the response!

I am very grateful for the response and assistance. I want to add for anyone reading these that my email (priv1.edb and priv1.stm)  mount with no problem, even after the defrag fails. My problem is that we moved the exchange 2003 server over easter weeknd (yup, defrag issue is getting old) and users can not perform searches or sort email. The issue is that only an offline defrag (the /d switch) will resolve this, and this is where we get the error. I opted out of thje eseutil /mh as I have only Friday evening through Monday 6AM to get this to work as email can't be down. As it is it takes about 3.5 hours to copy the edb and stm files along with the E00.chk and E00.log.

Early this morning I tripple chchked that this was in the path environmental variable  'c:\program files\exchsrvr\bin directory'. I also checked that the  /3GB /USERVA 3030 is set in the Boot.ini file and that the HeapDeCommitFreeBlock Threshold was set. I then re-ran the Best Practices Analyzer Tool to insure that everything is proper, it is.

Will run the eseutil /mh <database> tonight. My next attempt will be this Friday.

Thanks!

 
jawad1481Commented:
Hi!

You are most welcome .

do let us know if you need any help.

Thanks.

Jawad.
GilSimonAuthor Commented:
Smallov

I wish you the best luck - "Break a Leg", and all that.

We are still having the defrag problem here but email is working.

I am still interested in whether the isinteg will find any corruptions in our mail stores.
Tee CChief Know IT AllCommented:
I found running "eseutil /g" against the store fixed my problem.
I could then run "eseutil /p" against the same store without the error.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
smalloyCommented:
thedriver - your solutio worked for me. Although my connection cto the NAS Server crashed 2X.

Running eseutil /g first did the trick!!!



THNAK YOU
GilSimonAuthor Commented:
We will try it as well.

When we installed Service Pack 2 and raised the size off the store we bought ourselves time.  However, we still don't like the fact that the /d fails.

I will pass this on to the person who is performing the repairs and report back on it's effectiveness.

Thanks
reliablecomputersCommented:
Running eseutil /g and then was able to run eseutil /p fixing corruption.  

Thanks for your help..
coralbayccCommented:
None of these worked for me on my SBS 2003 box.  However I did find this post and it did.  
http://www.tcgtech.com.au/blog/?p=28

Louis Goler JREngineering ConsultantCommented:
I know this is an old post but I still have a client running Exchange 03.  I was able to copy ese.dll, eseutil.exe, exchmem.dll, exosal.dll and jcb.dll to the database folder (MDBData) hit OK on the error message and the defrag continued and finished properly.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.