Solved

How do I resolve the 553 sender is spoofed error when sending email from PHP to exchange?

Posted on 2009-05-03
3
1,422 Views
Last Modified: 2013-12-13
Hello!  We currently have a linux web server running cpanel with php at a remote location.  We recently installed an ms exchange 2007 server in our internal network which is protected by websense proxy.  On cpanel, I changed the A record for the MX entry to point to the exchange server's IP address and added the domain to the remotedomains file and removed from localdomains on the webserver and unchecked the box for always accept mail locally.  Lastly, we created a PTR (reverse DNS) record for exchange and the webserver IP addresses.

We have approximately 6 domains that will use exchange for mail.

Everything works fine except when I use PHP's mail() function from a web page to send email to and email address on exchange.  Each time I get a mail delivery failed message indicating 553: sender is spoofed.  I have googled for hours and came up with nothing.  Can anyone advise?  It is critical that the webpages be able to send email to an address on exchange as the webpages have contact forms on them.

I have tried the phpmailer script from sourceforge, tried Matt's formmail script, and even added the webserver IP to the exchange whitelist.  All to no avail.
0
Comment
Question by:bigeven2002
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 17

Accepted Solution

by:
Suraj earned 500 total points
ID: 24299488
On the Domain disable "Anti-Spoofing".

Server Configuration console --> E-mail Connection Management--> Protected
Domains--> Advanced--> "Deny messages with spoofed From addresses". Unselect this
option.

This might help you...

also enable the protocol logging to VERBOS  on the send and receive connector.
restart the transport service
let me know the results
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24306381
Ok I'm on Exchange Management Console: I see Server Configuration but I don't see E-mail Connection Management under it.  Could you clarify?
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 24318340
Sorry I didn't realize you were talking about Websense in the steps you mentioned.  I did verify that the box for deny messages with spoofed addresses was unchecked, but it had no effect.

I did manage to get it to work to an extent though, what I had to do was create a new SMTP receive connector in Exchange management console that pointed to the webserver's public IP address.  Then the mail finally went through.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The viewer will learn how to count occurrences of each item in an array.

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question