Solved

Cisco 2811 default route for specified network

Posted on 2009-05-03
7
827 Views
Last Modified: 2012-05-06
I have a Cisco 2811 router with two sub interface, and I want to setup a default route for only one of the sub interface, how can I do that? thanks
0
Comment
Question by:gcl_hk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 7

Expert Comment

by:egyptco
ID: 24293274
well basically you need the command:

ip route 0.0.0.0 0.0.0.0 <sub.interface>

make sure you assigned ip address to that subinterface and you have connectivity with the next hop before do this command if you don't like most of your traffic ending in blackwhole. on my 1700 router it says:
% Configuring IP routing on a LAN subinterface is only allowed if that subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or ISL vLAN.

so i need first to assign VLAN to the interface befor being able to route.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24293864
A route that reachable through a multiaccess network should have a next hop address. Specifying the interface instead of the next-hop address is used when the interface is connected to a point-to-point network.

ip route <network> <mask> <next hop address>

ip route 172.16.0.0 255.255.0.0 192.168.1.5

Open in new window

0
 
LVL 6

Author Comment

by:gcl_hk
ID: 24294151
Maybe I described not really clear.

Actually, I want the to implement the default route destination to the firewall for internet access, and the source network from one of the sub interface.

thanks
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 50

Expert Comment

by:Don Johnston
ID: 24294526
Routes don't have a "source". Only the destination network, mask and how to get there (outbound interface or next hop address).
0
 
LVL 7

Expert Comment

by:egyptco
ID: 24294621
ok, default route is configured as already mentioned

ip route 0.0.0.0 0.0.0.0 <next_hop_to_internet>

if you'd like to restrict only certain network to have access to internet (like the network on your sub-interface) you need to specify it in ACLs or do policy based routing if you wanted in more advanced way;).



 
0
 
LVL 6

Author Comment

by:gcl_hk
ID: 24301179
Am I right for the policy base routing of the attached code to achieve the requirement?
192.168.20.254 is the firewall

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 no ip route-cache cef
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 no ip route-cache
!
interface FastEthernet0/1.2
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 no ip route-cache
 ip policy route-map 10
!
access-list 10 permit 192.168.20.0 0.0.0.255
route-map 10 permit 10
 set ip default next-hop 192.168.20.254
!
route-map 10 permit 10

Open in new window

0
 
LVL 7

Accepted Solution

by:
egyptco earned 500 total points
ID: 24302508
well it seems ok to me. if your goal is to apply next hop your firewall for every host on your internal netowrk on the sub interface.
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month8 days, 11 hours left to enroll

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question