• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 775
  • Last Modified:

Configure Port duplex and speed on Cisco Switch

Hi, easy one for someone who knows how.
Basically I need to change the network port and duplex speed to auto and auto.
I need to change port Gi2/0/27. checked online and tried several commands but must be doing something wrong.

Thanks a lot
Port-status.bmp
0
kwatt562
Asked:
kwatt562
  • 5
  • 4
1 Solution
 
JFrederick29Commented:
It is set to auto/auto already as indicated by the a-full and a-100 with the "a-" referencing 100/Full determined by auto negotiation.
0
 
kwatt562Author Commented:
Ok but If I wanted to make a change?, as some are listed as just auto and some auto 100, the current setup is making the printer run painfully slowly and I need to find a port speed that will work.
0
 
JFrederick29Commented:
The difference is the ones that say "auto auto" are ports with nothing plugged into them.  The ones that have something plugged into it say "a-100 and a-full".  Are there errors on port?

show int g2/0/27
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
kwatt562Author Commented:
Thanks, there are no errors on the port. The printer only starting becoming slow when we changed from Hp to Cisco switches recently. The jetdirect card is set to auto. Have tried directly connecting the printer to the switch as well, also created local ports on the IP to bypass the print server, still very slow.
0
 
kwatt562Author Commented:
If i change the jetdirect card on the printer to 100FDx, the switch port changes to 100HDx?
0
 
kwatt562Author Commented:
Worth forcing the port to 100 FULL (no auto)?
0
 
JFrederick29Commented:
You need to change the switchport to match...

int g2/0/27
speed 100
duplex full
0
 
kwatt562Author Commented:
Apologies for being thick, but do I need to enter some kind of configuation mode, Im at the prompt
SW1>
0
 
JFrederick29Commented:
Yeah,

SW1>enable
Password:
SW1#config t
SW1(config)#int g2/0/27
SW1(config)#speed 100
SW1(config)#duplex full
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now