Solved

ASP Login

Posted on 2009-05-04
5
248 Views
Last Modified: 2012-05-06
I have a new ASP.Net 2.0 website I developed and am using the default ASPNETDB.MDF under the APP_DATA folder to store user name and passwords that I create using the Web Site Administration Tool.

I am trying to deploy this Web Site on a separate Windows 2003 server box and have copied the contents of my Web Project Folder into c:\Inetpub\wwwroot. So the APP_DATA is now a sub-folder of wwwroot.

When I run the Web Site in a browser it will not accept any logins that I had created on the development server, acts as if there are no user's setup. I have installed SQL Server Express on the production server but still no luck. Why?
0
Comment
Question by:michouis
  • 2
  • 2
5 Comments
 
LVL 21

Expert Comment

by:silemone
ID: 24297347
in the webconfig or where ever your connection string is for your db, is it pointing to the right db server?
0
 
LVL 41

Expert Comment

by:guru_sami
ID: 24297428
As mentioned in post above....first thing to check is it is pointing to correct database....
There could be may other reasons...
check this:
http://www.codeproject.com/KB/aspnet/LoginControlError.aspx
0
 

Author Comment

by:michouis
ID: 24297828
There is no connection string defined for this Express database file in my webconfig. I used the built-in ASP Login control and selected the default SQL Express provider. Then I setup user's using the Website Admin tool. Works great on the development server. Does not work on the production server. The ASPNET.MDF file is in C:\Inetpub\wwwroot\App_Data folder. Like i said, i installed Express SQL Server 2005 on the production box. Why is it not working?? I am typing the login/password values manually, same as i do on the development server... Must be some setting in SQL Express on the production server. Also, when you install Express SQL Server there is no Enterprise Managment tool included. How are you supposed to create any tables?
0
 
LVL 41

Accepted Solution

by:
guru_sami earned 500 total points
ID: 24297944
Since you don't have any setting in your web.config...the default settings are used from your machine.config.
Check the machine.config in your dev and prod machines ...look the connectionStrings section....
you will get better idea...

Try this:
In web.config.... add membership provider section as it is in the link in my previous post....
0
 

Author Closing Comment

by:michouis
ID: 31577632
I have solved this by adding a customized provider to use our main SQL Server 2005 database... thanks for your clues..
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

It was really hard time for me to get the understanding of Delegates in C#. I went through many websites and articles but I found them very clumsy. After going through those sites, I noted down the points in a easy way so here I am sharing that unde…
Get to know the ins and outs of building a web-based ERP system for your enterprise. Development timeline, technology, and costs outlined.
Viewers will get an overview of the benefits and risks of using Bitcoin to accept payments. What Bitcoin is: Legality: Risks: Benefits: Which businesses are best suited?: Other things you should know: How to get started:
This video teaches users how to migrate an existing Wordpress website to a new domain.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now