• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1228
  • Last Modified:

trixbox: no audio to/from/between extensions outside the PBX lan.

I have a trixbox on my LAN. The first time I installed it I had success communicating with remote SIP phones. Then I reinstalled trixbox and now remote uses can't hear or be heard on any call they make or receive.

2 users in the remote LAN can call each other but not hear each other.
0
ramrom
Asked:
ramrom
1 Solution
 
Kamran ArshadIT AssociateCommented:
Hi,

Seems the codec issue. If you can call each other but not hear voice then usually it is a codec issue. Which codec are you using?
0
 
ramromconsultant Author Commented:
How would I discover that?

I am using Xlite softphones and Zultys ZIP 2 hard phones.
0
 
koszegiCommented:
look in your sip.conf file and see which codec you are allowing for the SIP peers also check your network router/firewall to see if you don't have any ACL that is stopping UDP traffic.  Most likely you are just using the wrong codec between telephone endpoints. Using the wrong codec will cause wierd result.  Sometime you may get a call through, some time you get oneway communication, other time nothing at all. If bandwith is not an issue just use G711 throughout.
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
ramromconsultant Author Commented:
from sip_general_additional.conf: (generated by FreePBX - not to be edited)
allow=ulaw
allow=alaw
allow=h263
allow=h263a
allow=h264

I have put the trixbox in the firewall DMZ - bypasses all firewall protection.

I have observed via rtp debug that rtp packets are flowing between extensions.

I don't know how to specify codecs for the xLite softphone nor how to determine which it uses.
0
 
koszegiCommented:
verify your sip_nat.conf file that you specify the remote and local IP range.
externip=202.2.244.16             ; fjeanmar note - Public IP of asterisk
localnet=10.0.0.0/255.0.0.0     ; fjeanmar note - Local IP of asterisk

make sure the upper range ports uses to carry the voice traffic is open on your firewall.

check this link out.
http://www.freepbx.org/support/documentation/howtos/howto-setup-a-remote-sip-extension
0
 
koszegiCommented:
also, you could use a public stun server to make sure that NAT doesn't change the port for the audio stream and keep an active stream.  checkout http://www.voip-info.org for a list of public stun servers.  

To set the xlite codec you can go to the Xlite software settings page to specify what codec you prefer.  codec are G711ulaw, G711alaw, G726, 722, etc.
0
 
heim0698Commented:
Usually this problem is related to koszegi's reference above, make sure your sip_nat.conf file has:
nat=yes
externip=xxx.xxx.xxx.xxx

0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now