Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 713
  • Last Modified:

Remote Desktop not working

One of our XP users cannot seem to RDP into his own machine from another machine within the LAN. Remote access permission is set to "deny access" in his profile, as I understand that this is for connecting to the VPN from the outside and we don't want to allow this. But he can't RDP when he's inside the network. He has been added to the remote desktop user's group of his own machine, so what else could be the problem?
0
BobHavertyComh
Asked:
BobHavertyComh
  • 6
  • 4
1 Solution
 
Britt ThompsonSr. Systems EngineerCommented:
Is the Windows Firewall allowing access to port 3389? Or, is there an additional software firewall on the machine?

Does the user have a password? A password is require to use RDP.
0
 
BobHavertyComhAuthor Commented:
Yes, the user is part of our Active Directory and has a password. Windows Firewall is allowing access to port 3389, and actually, we use a cisco router as our firewall and 3389 is open, and other people can successfully RDP into their machines from another machine
0
 
Britt ThompsonSr. Systems EngineerCommented:
I see that the user has been added to the remote desktop users group of his own machine but, stupid question, is RDP enabled on that machine?

Can you use the command line and:   telnet computername 3389  ?
0
NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

 
BobHavertyComhAuthor Commented:
I did that on my own machine and I got a blinking cursor, so i guess I'm in and it's waiting for a telnet command. Should I have him do the same?
0
 
Britt ThompsonSr. Systems EngineerCommented:
that blinking cursor means it was successful. If his doesn't work then something is blocking the port and or RDP is not enabled. Or, the port number may have been changed in one way or another.

You can verify the port number here: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
0
 
BobHavertyComhAuthor Commented:
When he tries to rdp into his machine from another machine on the LAN it says that his interactive privledges have been disabled, please contact system administrator
0
 
BobHavertyComhAuthor Commented:
Remote desktop is definitely enabled on his machine and his domain user name is definitely part of remote desktop users on his machine
0
 
BobHavertyComhAuthor Commented:
did telnet machinename 3389 and it failed on his machine and said it could not connect to the host
0
 
Britt ThompsonSr. Systems EngineerCommented:
Oh...different story then. Sounds like there's a deny permission under his user account in the terminal services tab... see the image and make sure that checkbox is not checked in AD.
Picture-1.png
0
 
BobHavertyComhAuthor Commented:
ding ding ding. That's it. Thanks much
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Building an Effective Phishing Protection Program

Join Director of Product Management Todd OBoyle on April 26th as he covers the key elements of a phishing protection program. Whether you’re an old hat at phishing education or considering starting a program -- we'll discuss critical components that should be in any program.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now