• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 560
  • Last Modified:

Cisco ASA5505 VPN with PPoE

We have about 20 ASA5505's connected back to our VPN concentrator all using the same configs (other than the changes for the different internal network addressing).  They all work fine.  Now I've taken two more ASA5505's to setup through a different DSL provider that uses PPoE.  I can get the ASA to authenticate and pull a valid address, but the VPN tunnel does not come up.  

I can bring the ASA back to my house, remove the PPoE settings (my provider does not require) and plug it into my DSL conection and it comes right up.  Is there any trick when using PPoE that you need to account for other than setting the PPoE username and password?  When I look at the debug logs I don't see the external address that the ASA is given in any of the attempts to build a tunnel.  I can post some of the errors but thought I'd post this first.  
1 Solution
jpletcher1Author Commented:
I figured this out.  When you do PPoE there is an additional setting (checkbox) that you have to mark in order for the ASA to use the default ip route (gateway) that is given by PPoE.  Seems kind of odd that this isn't the default.  All we were getting was the IP address and subnet mask otherwise and obviously the ASA couldn't reach out to connect to our concentrator with not default route.  
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now