[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7182
  • Last Modified:

Could not load file or assembly "Infragistics35.WebUI.UltraWebListbarv9.1" or one of its dependencies. The system cannot find the file specified.

I have built an application using Infragistics components.  The application runs fine on my developement machine but when I copied all the files to my web server I get this error message.  I did copy the Infragistics .dll files to the c:\inetpub\wwwroot\webapp directory.  I thought if they were in the main directory, it should find the file.  Any ideas on how to solve this problem?

Here is the exact error message:

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Infragistics35.WebUI.UltraWebListbar.v9.1, Version=9.1.20091.1015, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' or one of its dependencies. The system cannot find the file specified.

Source Error:


Line 33:         <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
Line 34:         <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
Line 35:         <add assembly="Infragistics35.WebUI.UltraWebListbar.v9.1, Version=9.1.20091.1015, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
Line 36:         <add assembly="Infragistics35.WebUI.Shared.v9.1, Version=9.1.20091.1015, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
Line 37:         <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
 

Source File: C:\Inetpub\wwwroot\Rad Relay\web.config    Line: 35
0
kwh3856
Asked:
kwh3856
  • 3
  • 2
2 Solutions
 
RyanAndresCommented:
It may be searching for the files where .NET is installed.

ie. C:\Program Files\Microsoft.NET\Primary Interop Assemblies

Or, the version does not match.
0
 
SaedSalmanCommented:
rebuild the solution, if this not worked then copy the source code to a new solution
0
 
kwh3856Author Commented:
Ryan,
No luck with copying the files to the Interop directory
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
kwh3856Author Commented:
Found the problem.  I needed to copy the .dll files in the webapp/bin directory.  Once I copied the correct .dll files there, it worked properly.
0
 
SaedSalmanCommented:
Yes, right. rebuiled the solution might re-create the dll files, otherwise copy the source code to a new solution will surelly re-create the dll files.
0
 
kwh3856Author Commented:
I wanted to say thank you for each of you helping me with this problem.

Thanks
Kenny
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now