Solved

SBS 2003 to Server 2008/Exchange 2007 Migration Problems

Posted on 2009-05-04
3
674 Views
Last Modified: 2012-05-06
I am in the process of migrating our single server network from SBS 2003 to Server 2008.  The process so far:
1. Added Server2008 to the SBS domain
2. Promoted Server2008 to Domain Controller
3. Installed Exchange 2007 and migrated successfully (ran all the /prep stuff)
4. Added RRAS role to Server2008 and move PPTP VPN across successfully.
5. Changed Operations Masters (Infrastructure,PDC and RID) to Server2008

I am now trying to move the client logon across to Server2008 stuck with the following problems:
1.  There is no NETLOGON share on the Server2008.  If I create one it just disappears.
2.  When I run nltest /dsgetdc:mydomain on Server2008 I get the detail of the SBS server returned where I thought is should now return Server2008.
3.  dcdiag returns a number of errors (see below).

The actual names used for the lists below are:
Domain Name 'aussieadventuresailing'
SBS Server Name 'AASSERVER' static IP 192.168.127.1
Server2008 Name 'OASSERVER' static IP 192.168.127.2
DHCP on Server2008 allocates from pool 192.168.127.101/199

Any help would be appreciated.

-----------------NLTEST on OASSERVER (Server2008)--------------
 c:\>nltest /dsgetdc:aussieadventuresailing.local
           DC: \\AASSERVER.aussieadventuresailing.local
      Address: \\192.168.127.1
     Dom Guid: 4702b1c2-0b49-4350-9cc0-2cc62ce567d1
     Dom Name: aussieadventuresailing.local
  Forest Name: aussieadventuresailing.local
 Dc Site Name: Default-First-Site-Name
Our Site Name: Default-First-Site-Name
        Flags: GC DS LDAP KDC TIMESERV WRITABLE DNS_DC DNS_DOMAIN DNS_FOREST CLOSE_SITE
The command completed successfully

-----------------DCDIAG on OASSERVER (Server2008)--------------
Directory Server Diagnosis

Performing initial setup:
   Trying to find home server...
   Home Server = OASSERVER
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests
   
   Testing server: Default-First-Site-Name\OASSERVER
      Starting test: Connectivity
         ......................... OASSERVER passed test Connectivity

Doing primary tests
   
   Testing server: Default-First-Site-Name\OASSERVER
      Starting test: Advertising
         Warning: DsGetDcName returned information for
         \\AASSERVER.aussieadventuresailing.local, when we were trying to reach
         OASSERVER.
         SERVER IS NOT RESPONDING or IS NOT CONSIDERED SUITABLE.
         ......................... OASSERVER failed test Advertising
      Starting test: FrsEvent
         There are warning or error events within the last 24 hours after the
         SYSVOL has been shared.  Failing SYSVOL replication problems may cause
         Group Policy problems.
         ......................... OASSERVER passed test FrsEvent
      Starting test: DFSREvent
         ......................... OASSERVER passed test DFSREvent
      Starting test: SysVolCheck
         ......................... OASSERVER passed test SysVolCheck
      Starting test: KccEvent
         ......................... OASSERVER passed test KccEvent
      Starting test: KnowsOfRoleHolders
         ......................... OASSERVER passed test KnowsOfRoleHolders
      Starting test: MachineAccount
         ......................... OASSERVER passed test MachineAccount
      Starting test: NCSecDesc
         Error NT AUTHORITY\ENTERPRISE DOMAIN CONTROLLERS doesn't have
            Replicating Directory Changes In Filtered Set
         access rights for the naming context:
         DC=ForestDnsZones,DC=aussieadventuresailing,DC=local
         Error NT AUTHORITY\ENTERPRISE DOMAIN CONTROLLERS doesn't have
            Replicating Directory Changes In Filtered Set
         access rights for the naming context:
         DC=DomainDnsZones,DC=aussieadventuresailing,DC=local
         ......................... OASSERVER failed test NCSecDesc
      Starting test: NetLogons
         Unable to connect to the NETLOGON share! (\\OASSERVER\netlogon)
         [OASSERVER] An net use or LsaPolicy operation failed with error 67,
         Win32 Error 67.
         ......................... OASSERVER failed test NetLogons
      Starting test: ObjectsReplicated
         ......................... OASSERVER passed test ObjectsReplicated
      Starting test: Replications
         ......................... OASSERVER passed test Replications
      Starting test: RidManager
         ......................... OASSERVER passed test RidManager
      Starting test: Services
         ......................... OASSERVER passed test Services
      Starting test: SystemLog
         An Warning Event occurred.  EventID: 0x00001696
            Time Generated: 05/05/2009   07:42:18
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Warning Event occurred.  EventID: 0x80040020
            Time Generated: 05/05/2009   07:49:28
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Warning Event occurred.  EventID: 0x80040020
            Time Generated: 05/05/2009   07:49:28
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Warning Event occurred.  EventID: 0x80040020
            Time Generated: 05/05/2009   07:49:28
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Warning Event occurred.  EventID: 0x8000001D
            Time Generated: 05/05/2009   07:49:30
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Warning Event occurred.  EventID: 0x00001696
            Time Generated: 05/05/2009   07:49:32
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Error Event occurred.  EventID: 0xC0002720
            Time Generated: 05/05/2009   08:00:45
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Error Event occurred.  EventID: 0xC0002720
            Time Generated: 05/05/2009   08:00:45
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         An Error Event occurred.  EventID: 0xC0002720
            Time Generated: 05/05/2009   08:00:45
            EvtFormatMessage failed, error 15100 Win32 Error 15100.
            (Event String (event log = System) could not be retrieved, error
            0x3afc)
         ......................... OASSERVER failed test SystemLog
      Starting test: VerifyReferences
         ......................... OASSERVER passed test VerifyReferences
   
   
   Running partition tests on : ForestDnsZones
      Starting test: CheckSDRefDom
         ......................... ForestDnsZones passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... ForestDnsZones passed test
         CrossRefValidation
   
   Running partition tests on : DomainDnsZones
      Starting test: CheckSDRefDom
         ......................... DomainDnsZones passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... DomainDnsZones passed test
         CrossRefValidation
   
   Running partition tests on : Schema
      Starting test: CheckSDRefDom
         ......................... Schema passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... Schema passed test CrossRefValidation
   
   Running partition tests on : Configuration
      Starting test: CheckSDRefDom
         ......................... Configuration passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... Configuration passed test CrossRefValidation
   
   Running partition tests on : aussieadventuresailing
      Starting test: CheckSDRefDom
         ......................... aussieadventuresailing passed test
         CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... aussieadventuresailing passed test
         CrossRefValidation
   
   Running enterprise tests on : aussieadventuresailing.local
      Starting test: LocatorCheck
         ......................... aussieadventuresailing.local passed test
         LocatorCheck
      Starting test: Intersite
         ......................... aussieadventuresailing.local passed test
         Intersite

0
Comment
Question by:Whitsundays_Greg
3 Comments
 

Accepted Solution

by:
Whitsundays_Greg earned 0 total points
Comment Utility
After 100's of dead ends I managed to fix the SYSVOL/NETLOGON issues using the brflags as outlined in http://support.microsoft.com/kb/290762.

I was disappointed the "Experts" were not able to point me to this solution earlier.

Cheers.
0
 

Expert Comment

by:powerone
Comment Utility
What exactly did you do and on which server did you end up resoring etc..?

Im having the same issue with sbs2003 to sbs 2008 64 bit
0
 

Expert Comment

by:trusnock
Comment Utility
That KB article doesn't even mention 2008, so I, too, am wondering what exactly was done, and on which server.  I'm having the same issue after doing a migration installation from 2003 SBS to 2008 SBS 64-bit.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now