Solved

Error - Access Denied when acessing HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Posted on 2009-05-04
15
6,299 Views
Last Modified: 2012-05-06
When I try to install applications they fail with a permissions error when accessing HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

I have tried regedit, right clicking on permissions. It tells me that I don't have permission to view... but can make changes. In the permissions dialog there are no users or groups i the list. I can add users but when I apply the changes I get access denied.

I have also tried this from UBD4WIN using remote registry editor with the same result.

Any Ideas.

0
Comment
Question by:alan-blair
  • 7
  • 3
  • 2
  • +3
15 Comments
 
LVL 10

Expert Comment

by:Vince Glisson
Comment Utility
Are you on a domain?
Are you an Admin on that domain?
 
0
 

Author Comment

by:alan-blair
Comment Utility
No, this is an XP Home machine.

I tried logging on as Administrator in safe mode with the same result.
0
 

Author Comment

by:alan-blair
Comment Utility
Any ideas??

Everything else on this PC works. It's only when you try to install some apps, they won't install and I get a permission error with this key.

I can't do a restore because they had it turned off.

I don't want to do a reload for such a small issue.

I have also tried using subinacl as per the following link. http://www.winhelponline.com/blog/reset-the-registry-and-the-file-permissions-in-windows-xp/

Any ideas would be helpful.
0
 
LVL 10

Expert Comment

by:Vince Glisson
Comment Utility
The account that you are logged in with, is it an administrator's account?
It appears to me that the account that you are logged in with is not an administrators account.
If it is and you can't install or make changes then you need to verify that you have a legal copy of windows.
Can you verify that you are using "Genuine Windows Software"?
 
0
 

Expert Comment

by:MubarakHA
Comment Utility
Try by taking the ownership of that key
right click and choose permission, then click Advanced. from the advanced window click on the owner tab. you should see some names including the administratos local security gorup. select the user or group that you want and and check the Replace ownership on subcontainer and click apply.
let me know if it works for you
0
 

Author Comment

by:alan-blair
Comment Utility
Thank you for your replies.

OK.. I logged in as Administrator in safe mode. In safe mode I can see the permissions.

I changed the owner of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows to "Administrators". I even gave "Everyone" full control.

The Key is empty except for "Default". If I try to add a DWORD I get "Access Denied".

I tried going back to the Key permissions and "Replace permission entries on all child objects...". Again I get "Access Denied".

I'm just running subinacl with the reset script again and the Key Owner set to Administrators. Hopefully this will do something.

Thanks again.
0
 

Author Comment

by:alan-blair
Comment Utility
OK.. The script just finished and it is still the same.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Expert Comment

by:MubarakHA
Comment Utility
Have you tried this:
 
right click and choose permission, then click Advanced. from the advanced window click on the owner tab. you should see some names including the administratos local security gorup. select the user or group that you want and and check the Replace ownership on subcontainer and click apply.
0
 

Author Comment

by:alan-blair
Comment Utility
Yes...

I can take ownership of the Key. However, if I select "Replace ownership on subcontainer" I get access denied when I apply.

By the way, I have just tried a windows repair installation with no success.  

AHHHH Stupid Windows!  looking like a reload!
0
 

Author Comment

by:alan-blair
Comment Utility
Also, I just tried to export the key and I get an error saying "The selected branch does not exist".
0
 
LVL 10

Expert Comment

by:Vince Glisson
Comment Utility
If you continue to get access denied errors then the account you are logged in with just doesn't have sufficient permission to make the changes.
Continuing to attempt to take control of keys and/or folders may make this situation worse and in the end you'll need to re-install anyway.
So i agree that starting from scratch with a fresh install is the way to go...
 
0
 

Accepted Solution

by:
alan-blair earned 0 total points
Comment Utility
Thanks for your efforts guys. I did end up doing a reload.

It's frustrating that even the Administrator can be locked out of objects. Even more so that Microsofts own tools are incapable of fixing this.

Mind you if Windows was a perfect OS I would be out of a job.

Thanks again,
Alan.
0
 

Expert Comment

by:mbrunstedt
Comment Utility
For what it is worth, I was able to get the permissions to work on this key by doing the following:

Right-click the key and add the local admin account not the domain admin account.
So if your local computer name was COMPUTER1 then type in COMPUTER1\Administrator.

Once that was added, all the other permissions repopulated (Everyone, User, etc) and now I can do whatever is needed. The items in that folder also reappeared (7 items total for me). Hope this helps someone to not have to reinstall Windows!!!

0
 

Expert Comment

by:LibWines
Comment Utility
Hi All

I had a similar problem and found that I had two deny entries for Everyone in Right Click -> Permissions -> Advanced -> Permissions

I believe these entries were added by Malware that I had cleaned off of the system.
0
 
LVL 1

Expert Comment

by:SCMComputers
Comment Utility
Another thing to look for is, which can be easily overlooked, is once you have taken ownership do the following steps:
Click OK to close the Permissions
Reopen the permissions and again select Advanced
If there are DENY entries - check who they are for (in this case most likely Comptuer\Administrators)
Check - Replace all existing inheritable permissions on all descendents with inheritable permissions from this object
Click - Apply or OK

This should resolve your problem without the need to rebuild the computer.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

This is a little timesaver I have been using for setting up Microsoft Small Business Server (SBS) in the simplest possible way. It may not be appropriate for every customer. However, when you get a situation where the person who owns the server is i…
Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now