• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 355
  • Last Modified:

XP Pro systems very slow logging onto Domain

Recently promoted a 2003 Std Server to a domain controller.  The existing workgroup users were promoted to the active directory users although they have weak passwords - they still log on to the domain.  It takes approx 3 or so minutes to log on to the domain on a XP Pro system.  I'm assuming this is some sort of Group Policy switch that needs turned off?  How do we fix this?
0
randyphillips
Asked:
randyphillips
  • 3
  • 3
  • 3
  • +3
5 Solutions
 
rettif9ManagerCommented:
Did you create A records for the computers in DNS?
0
 
Vince GlissonOwnerCommented:
When you say " The existing workgroup users were promoted to the active directory users"
exactly how did you accomplish that.
I would change the users passwords to strong passwords (regardless if it's slow or not as it is better for your security, and you'll be able to eliminate that as a possible reason for the slowness)
After you promoted the server did you join  the computers to the domain?
 
 
 
0
 
randyphillipsAuthor Commented:
We had a 2003 std server functioning as a simple "workgroup" server with a handful of XP Pro systems connecting via mapped drives.  Then - promoted to a domain dcpromo due to some new ERP software using domain auth for their software.  The dcpromo went slick and plopped the existing workgroup users into the Active Directory User List.  They are showing up as domain users, etc.  I joined the XP Pro systems to the domain via the "change" function and they can indeed log on fine but takes VERY long - 3 or so minutes.  These are brand spanking new XP Pro SP3 - all win updates, etc.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
randyphillipsAuthor Commented:
Under "locations" on the workstations I can't see the domain either - only the local system.  That seems strange too but I am indeed logged into the domain.
0
 
Mark PavlakCommented:
9 out of 10 times when this occurs DNS is the problem.  Make sure your DNS entries on the workstations point back to the DC
0
 
Vince GlissonOwnerCommented:
Did these workstations have static ip addresses and manual entries for DNS servers?
Were these clients set to receive DHCP and DNS settings automatically?
You would need to verify this on each workstation...
ipconfig /all will tell you where they are getting the DNS from, see if it is from an expected source or from somewhere else.
0
 
Randy_BojanglesCommented:
Got to be DNS issue

If its only a low number of clients then you could achieve what you want with a HOSTS file if you're not comfortable with DNS/DHCP settings
0
 
zen_68Commented:
Yep, a DNS issue for sure. Make sure the clients point to the dc's ip for DNS before they join, and it'll be down to 3 seconds instead of 3 minutes.
0
 
rettif9ManagerCommented:
Configure your SBS server as the DNS server for your network
http://support.microsoft.com/kb/323380 
Then configure all workstations to point to server for DNS or run DHCP on server
0
 
Vince GlissonOwnerCommented:
retti9, why do you think this is a SBS?
Description states it was a 2003 std box that was promoted to a dc.
0
 
rettif9ManagerCommented:
Sorry, retract previous comment please. Wrong version of server. Here's the right kb article I believe.
http://support.microsoft.com/kb/323380
You may also need to add Host (A) records for your workstations and you will need to configure the workstations to use the server for DNS. The easiest way to do this is to enable the DHCP server in W2K3 and assign the DNS server through DHCP.
http://technet.microsoft.com/en-us/library/cc756865.aspx?ppud=4
0
 
randyphillipsAuthor Commented:
Thanks for the confirmation.   I noticed that when connecting to the DC that Vista and Win2008 prompted for a pri dns setting.  That red flagged this config.  I did not set the pri dns on the XP Pro ws'.  Caused a 3 min logon delay to the domain.  Simply set the pri dns to the IP of the DC and the sec to internet dns and SHAZAM!!   XP Pro logon is normal  - 1 or 2 seconds!!    Thanks EVERYONE!    Sweet!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 3
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now