• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 601
  • Last Modified:

Vista RDP saving logon credentials

Here is my issue. I have a Windows Vista Home Premium laptop that I am trying to do remote desktop to a Windows 2003 Terminal Server. When I make the connection it is to a dynamic host which is southerntaxsvs.dyndns.org. Every time i try to connect the RDP connection will place the domain name in front of the username. Lets take for example the user name is tsmith. It adds the connection of the computer name to the connection string and makes it southerntaxsvs.dyndns.org/tsmith when it should only be tsmith. How can I correct this. It only seems to be happening on this machine. I have a Windows Vista Ultimate pc that lets me connect correctly. This question is really important and I will award the highest points to the person with the answer to this issue. I am working on a deadline of Wednesday and need a fix quick. I am off now but will be checking this first thing in the am. Thanks in advance for your assistance.
0
James Hanks
Asked:
James Hanks
  • 4
  • 3
2 Solutions
 
JohnBusiness Consultant (Owner)Commented:
I have no problems with a Vista Business 64-bit computer either. One would generally avoid a Home computer for business use. Is it possible to use a proper computer? Can you blank out the name and type in tsmith? This part I cannot tell, because I don't have the problem. I tried it as well on my XP Pro computer, and no issue. I would like to assist but I cannot replicate the problem.  ... Thinkpads_User
0
 
JohnBusiness Consultant (Owner)Commented:
One thing you might try (Oh how I wish I could edit posts): Pull up RDP, click on Options to expand the dialogue window, and uncheck the button that says Allow me to save credentials.
... Thinkpads User.
0
 
James HanksIT TechnicianAuthor Commented:
There is no way this person is going to spring for a new pc and I have to just try and make it work. I have tried to edit the credentials, it will let me change the user name but will still leave the domain name. Have also tried to uncheck the box that says to save credentials and that does not help either. I am going to try and add a line to the hosts file that points the dynamic name to the domain name on the laptop and see where that takes me. Any more suggestions??
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
JohnBusiness Consultant (Owner)Commented:
For the one client I have behind dyndns.org, I do not have this problem. I VPN into the client and RDP works well. I use my HOSTS file to map specific remote internal addresses to domain names and that works, but I don't know if it will assist in this situation. Do try and let us know.

What are the possibilities of  trying to upgrade this computer from Home to Business (not replace the computer).

As, if not more, expensive, what about putting in a VPN so that users are not using the dyndns.org name? I am reluctant about this because it will affect all the users. On the other hand, you told us here how to access your system and I did. You then rely upon our goodwill not to attack your system. I never, never would, so I am just making this security point.
... Thinkpads_User
0
 
James HanksIT TechnicianAuthor Commented:
As for as the security, I provided the dyndns name so you could test. The username that I gave you was bogus.

The hosts file rectified the problem. I added the ip address of the dyndns to the hosts file and pointed to the domain that I was connecting. Had it save the credentials so that when it signed on it used the domain/username correctly. This seems like a work around that is unnecessary but if that is the only solution then so be it. Thanks.
0
 
James HanksIT TechnicianAuthor Commented:
I accept the soluttion and award the points
0
 
James HanksIT TechnicianAuthor Commented:
none
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now