Exchange 2007/Outlook 2007 Autodiscover FAILED 0x80072F78

I've noticed an issue where the Offline Address Book doesn't seem to be downloading. I've been through quite a few posts on this forum as well as others checking over a lot of settings. Basically what I've got is this:
Output of Test-OutlookWebServices:

[PS] C:\Windows\system32>Test-OutlookWebServices -identity user.name | fl


Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address user.name@domain.com.

Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://exchange-server.domain.local/Autodiscover/Autodiscover.xml.

Id      : 1016
Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://exchange-server.domain.local/EWS/Exchange.asmx. The elapsed time was 234 milliseconds.

Id      : 1015
Type    : Success
Message : [EXCH]-Successfully contacted the OAB service at https://exchange-server.domain.local/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

Id      : 1014
Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://exchange-server.domain.local/UnifiedMessaging/Service.asmx. The elapsed time was 140 milli
          seconds.

Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.

I can also start Outlook for the first time and successfully connect to the mailbox using the auto configuration. However, I can't download the Offline Address Book and when I right click the Outlook icon and click Test E-mail AutoConfiguration it fails with the following error:
Results:
Autoconfiguration has started, this may take up to a minute
Autoconfiguration was unable to determine your settings!
Log:
Attempting URL https://exchange-server.domain.local/Autodiscover/Autodiscover.xml found through SCP
Autodiscover to https://exchange-server.domain.local/Autodiscover/Autodiscover.xml starting
Autodiscover to https://exchange-server.domain.local/Autodiscover/Autodiscover.xml FAILED (0x80072F78)
It then proceeds to fail all other attempts.
I would appreciate any advice or suggestions to fix this, not that it's causing any problems but nevertheless it's something that isn't working the way it should.

Thanks
tclcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
esmith69Commented:
Have you specified an offline address book for your mailbox store?  I'd also run the tests at https://testexchangeconnectivity.com and see what those results say.
0
 
tclcAuthor Commented:
Under Organization Configuration > Mailbox > Offline Address Book, I have the Default Offline Address Book, it's configured as such:
General tab:
Update Schedule: Run daily at 4:00AM
Address Lists tab:
Include the default Global Address List
Distribution tab:
Outlook 2003 or later (Version 3)
Outlook 2003 SP2 or later (Version 4)
Enable Web-based distribution
Distribute the offline address book from these virtual directories:
OAB (Default Web Site) - exchange-server
Enable public folder distribution

Exchange is configured basically to be internal only. There is no access to it externally (yet). So those tests won't work.

Thanks for the help.
0
 
Debug-ExchangeCommented:
Hi,
I am assuming that you are using Single Exchange server with all roles please mention if you have a different configuration
please try and brows this URL from the internal client machine (Domain joined)
https://exchange-server.domain.local/Autodiscover/Autodiscover.xml (It should give you Error 600)

please follow the KB 940726 to change the SCP object
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
esmith69Commented:
Sorry, I misspoke.  I meant to ask if you had specified a default public folder store for your mailbox store.  That setting is under the properties for your mailbox store, under "server configuration"
0
 
tclcAuthor Commented:
@Debug-Exchange:
Yes, everything except the Edge Transport role is installed on a single server.
When browsing to the URL given I do get the Error 600 Invalid Request.
Will try the suggested resolution given in KB940726 now, will let you know how I go.

@esmith69:
Ah, my mistake. For the Mailbox Database Properties, on the Client Settings tab I have these settings configured:
Default public folder database:
exchange-server\Second Storage Group\Public Folder Database
Offline address book:
\Default Offline Address Book

Regards
0
 
tclcAuthor Commented:
Thank you for your help Debug-Exchange. For some reason setting the server name to the FQDN wouldn't work so had to replace it with another name on the certificate/DNS. Thanks for everyone's help. Much appreciated.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.