Solved

Exchange 2007/Outlook 2007 Autodiscover FAILED 0x80072F78

Posted on 2009-05-04
6
3,373 Views
Last Modified: 2012-05-06
I've noticed an issue where the Offline Address Book doesn't seem to be downloading. I've been through quite a few posts on this forum as well as others checking over a lot of settings. Basically what I've got is this:
Output of Test-OutlookWebServices:

[PS] C:\Windows\system32>Test-OutlookWebServices -identity user.name | fl


Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address user.name@domain.com.

Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://exchange-server.domain.local/Autodiscover/Autodiscover.xml.

Id      : 1016
Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://exchange-server.domain.local/EWS/Exchange.asmx. The elapsed time was 234 milliseconds.

Id      : 1015
Type    : Success
Message : [EXCH]-Successfully contacted the OAB service at https://exchange-server.domain.local/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

Id      : 1014
Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://exchange-server.domain.local/UnifiedMessaging/Service.asmx. The elapsed time was 140 milli
          seconds.

Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.

I can also start Outlook for the first time and successfully connect to the mailbox using the auto configuration. However, I can't download the Offline Address Book and when I right click the Outlook icon and click Test E-mail AutoConfiguration it fails with the following error:
Results:
Autoconfiguration has started, this may take up to a minute
Autoconfiguration was unable to determine your settings!
Log:
Attempting URL https://exchange-server.domain.local/Autodiscover/Autodiscover.xml found through SCP
Autodiscover to https://exchange-server.domain.local/Autodiscover/Autodiscover.xml starting
Autodiscover to https://exchange-server.domain.local/Autodiscover/Autodiscover.xml FAILED (0x80072F78)
It then proceeds to fail all other attempts.
I would appreciate any advice or suggestions to fix this, not that it's causing any problems but nevertheless it's something that isn't working the way it should.

Thanks
0
Comment
Question by:tclc
  • 3
  • 2
6 Comments
 
LVL 9

Expert Comment

by:esmith69
ID: 24301577
Have you specified an offline address book for your mailbox store?  I'd also run the tests at https://testexchangeconnectivity.com and see what those results say.
0
 

Author Comment

by:tclc
ID: 24301704
Under Organization Configuration > Mailbox > Offline Address Book, I have the Default Offline Address Book, it's configured as such:
General tab:
Update Schedule: Run daily at 4:00AM
Address Lists tab:
Include the default Global Address List
Distribution tab:
Outlook 2003 or later (Version 3)
Outlook 2003 SP2 or later (Version 4)
Enable Web-based distribution
Distribute the offline address book from these virtual directories:
OAB (Default Web Site) - exchange-server
Enable public folder distribution

Exchange is configured basically to be internal only. There is no access to it externally (yet). So those tests won't work.

Thanks for the help.
0
 
LVL 2

Accepted Solution

by:
Debug-Exchange earned 250 total points
ID: 24303174
Hi,
I am assuming that you are using Single Exchange server with all roles please mention if you have a different configuration
please try and brows this URL from the internal client machine (Domain joined)
https://exchange-server.domain.local/Autodiscover/Autodiscover.xml (It should give you Error 600)

please follow the KB 940726 to change the SCP object
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 9

Expert Comment

by:esmith69
ID: 24305122
Sorry, I misspoke.  I meant to ask if you had specified a default public folder store for your mailbox store.  That setting is under the properties for your mailbox store, under "server configuration"
0
 

Author Comment

by:tclc
ID: 24309688
@Debug-Exchange:
Yes, everything except the Edge Transport role is installed on a single server.
When browsing to the URL given I do get the Error 600 Invalid Request.
Will try the suggested resolution given in KB940726 now, will let you know how I go.

@esmith69:
Ah, my mistake. For the Mailbox Database Properties, on the Client Settings tab I have these settings configured:
Default public folder database:
exchange-server\Second Storage Group\Public Folder Database
Offline address book:
\Default Offline Address Book

Regards
0
 

Author Closing Comment

by:tclc
ID: 31578268
Thank you for your help Debug-Exchange. For some reason setting the server name to the FQDN wouldn't work so had to replace it with another name on the certificate/DNS. Thanks for everyone's help. Much appreciated.
0

Featured Post

Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
outlook 2013 8 27
cached or not 5 39
Email subject no showing 2 26
Outlook.com timing out while writing email 4 10
Utilizing an array to gracefully append to a list of EmailAddresses
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now