Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Can't RDP into the server

Posted on 2009-05-04
7
Medium Priority
?
374 Views
Last Modified: 2013-11-21
I tried installing Terminal Services from Elusiva on a Server running Server 2003.  They offer it a little cheaper and I was happy with their Terminal Services pro on Xp which provides a good solution for small business.

I didn't work out too well for Server 2003 standard however so I uninstalled it. The config is set to remote desktop for administration but when I try to log in (domain admin) I get:

To log on to this remote computer, you must have Terminal Server User Access Permissions on this computer. By default, members of the Remote Desktop group have these permissions. If you are not a member of the Remote Desktop Users group or another group that has these permissions, or if the Remote Desktop User group does not have these permissions, you must be granted these permissions manually.


I tried:
1.      Run Add/Remove Programs (run "appwiz.cpl")
2.      Click Add/Remove Windows Components (Alt-W)
3.      Uncheck Terminal Server
4.      Press Next>.
5.      Follow instructions, including rebooting.
6.      Open System control panel applet (run "sysdm.cpl")
7.      Click Remote tab.
8.      Check Enable Remote Desktop on this computer. (because removing Terminal Server disables this)
9.      Click Select Remote Users...

Everything I can find says that Terminal Services is in admin mode but still I get that error one would get if a user was not in remote desktop group and it was in applications mode.  Is there a key I need to check or something?

Thanks
Lee
0
Comment
Question by:ccampbell15
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 4

Expert Comment

by:Macros82
ID: 24301581
First things first. Have you checked: Enable remote desktop on this computer in System properties
0
 
LVL 4

Expert Comment

by:Macros82
ID: 24301582
Oops ignore that comment
0
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24302868
1. Check to see if the account you are trying to connect as is a member of the Remote Desktop Users group. (Go to Start > Run and enter  "control userpasswords2" > Advanced Tab> Advanced user Management and check membership on "Remote Desktop Users" group.

2. Open Gpedit and check the user account/Remote Desktop Users group is allowed to log on through terminal services. (Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment > Allow log on through Terminal Services)

Hope this helps.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 2

Author Comment

by:ccampbell15
ID: 24303024
I have disabled (or so I think) applications mode and am logging in as a domain admin. Remote is enabled in the system icon of program files.  I can't use the first snap-in you mention because it's a DC. Small business and the ONE Server is everything.

Remote desktop users group should not be allowed to login via TS at this point since it's in remote admin mode.

TY
0
 
LVL 14

Accepted Solution

by:
Raj-GT earned 2000 total points
ID: 24303079
In which case the GPO should have the Administrators group.
Also check under Terminal Services Configuration > RDP-Tcp properties > Permissions tab to see if the Administrators group has full rights to connect to the server.

0
 

Expert Comment

by:Reejish
ID: 24303628
Are you able to telnet to port 3389?
0
 
LVL 2

Author Closing Comment

by:ccampbell15
ID: 31577878
Hey,
You were right!  I never edited this GPO so it's a bit of a mystery how/why it was changed.

Thanks
Lee

0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found here: http://www.experts-exchang…
Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question