Spam Relay Problems

I hope someone can shed some light onto thiw. None of the solutions I have found have worked.

A customer has an SBS 2003 server running exchange. They use SMTP for both incoming and outgoing mail.

Someone is sending 1000's of mails through their server as postmaster@theirdomain.com

I have tried all sorts to block them but they appear to have random IP addresses. If I disable SMTP relay then nobody can send or recieve mails. If I turn on authentication then outside servers cannot send mail to their mail server.

Hope someone has come across this before.

Thanks in advance
jgearhartAsked:
Who is Participating?
 
Rajith EnchiparambilConnect With a Mentor Office 365 & Exchange ArchitectCommented:
This is NDR attack. Configure recipient filtering, smtp tarpitting.

Follow this article in full http://www.amset.info/exchange/spam-cleanup.asp

http://enchiparambil.com/smtp_tarpitting_for_exchange.aspx

Rajith.
0
 
Rajith EnchiparambilConnect With a Mentor Office 365 & Exchange ArchitectCommented:
0
 
g000seConnect With a Mentor Commented:
Helllo,

In Exchange look under- Message Delivery.  You can block the Spam
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
jgearhartAuthor Commented:
I have checked using telnet and according to that the system is secure. I am at a loss to explain how they are managing to send mails through the server. They are sending them using out own postmaster address which I understand cannot be disabled.

The mail is going out FROM the server as postmaster not incoming as postmaster.

Is there a way to secure this so that only the system can recreate an outgoing mail as postmaster?

I have managed to stop the mails from leaving the server but they are just backing up in the queues now at a rate of about 600 per hour.

Any suggestions?

I have a watchguard x10e by the way if anyone has any suggestions on additional configuration options.
0
 
Rajith EnchiparambilConnect With a Mentor Office 365 & Exchange ArchitectCommented:
have you configured IMF in Exchange 2003, especially sender id filtering? What about smtp tarpitting?

Configure IMF as a measure to fight spam. In your case, it seems like the spammer is sending emails to non-existent users in your domain and your server is responding with an ndr when the user is not found.

http://www.petri.co.il/block_spam_with_exchange2003_imf.htm
0
 
g000seConnect With a Mentor Commented:
Using the message delivery in Exchange is a no cost solution in fighting against SPAM.  You can also block it at the client level too in Outlook.
0
 
jgearhartAuthor Commented:
I managed to solve the problem using the watchguard SMTP proxy built into the router.

This seems to be the solution with the lowest resource overhead since the server is not particually powerful.

I basically told the router to reject all mails in both directions for postmaster@domain.com

This seems to have cured the problem.

Many Thanks for all your comments

I have split the points between you because nobody came up with a solution that solved the problems but you all pointed me in the correct direction.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.