SSL Certificate configuration

I have set up a certificate for exchange and outlook anywhere, but it does not appear to work.
I have tested it on the testing website and it reported the following error (see attached)

Setup:
My Exchange server sits behind a router.  HTTPS port open
external connection - gateway.pyramid-products.com
internal connection - svr2.pyramid.local
Certificate by - godaddy.com

Laptop connected on internal network - works ok + Outlook anywhere proxy settings set to external address.

The connection to OWA works fine.  Active sync devices work OK (ipaq + iphone)
When I try to connect from an external source on the laptops using the outlook anywhere settings it does not work. It request a username and password and advises will not work.

Can someone please advise what exactly is wrong and what i can do to fix it.

sync-errors.pdf
LVL 5
dexterhomeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
ilantzCommented:
is the server you installed exchange 2007 on is 2008 ?
have you configured properly the outlook anywhere settings , that is entering external name & choosing BASIC/NTLM ?
you sure you configured the outlook client properly ?
0
 
ilantzCommented:
humm and.. did you try to configure the profile manually , not using the autodiscover with outlook 2007 ?
that is outlook 2003 "style" ..
0
 
dexterhomeAuthor Commented:
Outlook configured on machine while connected internally - works fine.
Outlook anywhere set to the httpS address and does not work

But owa works all ok.
The other test on the test site appear to work, but more investigation reveals some still have cert warnings but work.

Any ideas.

PS: I will check my server settings
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
ilantzCommented:
your certificate is fine , it has the correct SAN entries inside, and i saw it works.
while testing inside the lan , did you checked to connect on FAST and SLOW networks ? and verified that outlook is connected with https ?
i'll wait for more server info , but  if its a server 2008 , and it's an all-in-one server (all roles) you need to do the following:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
add 32bit Dword , DisabledComponents with value 0xffffffff

then, edit the server HOSTS file , add the server ip and map it to its nbt + fqdn name:

1.1.1.1   NETBIOSNAME
1.1.1.1   FQDNNAME.DOMAIN.CORP

restart server after this change.
0
 
dexterhomeAuthor Commented:
Server info.
Windows server 2003 STD edition SP2
Exchange server 2007 STD editions SP1

Server is a domain controller with FSMO roles.
Exchange is front and back in one - transport and edge configured.
New to Exchange 2007 so wording may wrong.
0
 
ilantzCommented:
i'll need some output ..

from the exchange shell paste me outputs of :

get-outlookanywhere

get-clientaccessserver | fl

Get-AutodiscoverVirtualDirectory | fl
0
 
dexterhomeAuthor Commented:
Here are the outputs.  All in one file.
svr2-report.txt
0
 
ilantzCommented:
i see you configured NTLM for client authentication. for that to work you must use configure the certificate principle name (Issued To:) in outlook anywhere settings within your outlook profile. i've attached the sample for you.

if it still fails , run the following to make sure it is configured.

Set-OutlookProvider EXPR -Server SRV2 -CertPrincipalName msstd:gateway.pyramid-products.com

hope this solved it.
msstd.PNG
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
dexterhomeAuthor Commented:
I only set the system with NTLM after you advised me to check it earlier.
I originally just had it set with normal authentication - It just asked for a password and failed.

I will now change the settings as above and re-advise afterwards.
0
 
dexterhomeAuthor Commented:
I have now changed those settings and it appears to work OK.

Now the interesting bit - my boss (in China at moment) has the issue.
Should I (how do I) get it outlook to talk to the exchange server through external gateway link when not already configured with internal connection.

0
 
ilantzCommented:
great !
well, autodiscover profile is only when creating a new one , i dont think you want that for your boss ....
just send him directions and the screenshot of the settings and he'll be fine.
0
 
dexterhomeAuthor Commented:
Have just tried from home and appears to work OK.  few!

He is in China and I leave for Egypt before he gets back so could have been nasty.
0
 
ilantzCommented:
great job.
0
 
dexterhomeAuthor Commented:
The laptop is not actually part of my business domain - so it will keep asking for the password every time outlook is opened.  Is there any way around this.

I know I could just ask him to make his local password the same as the domain/exchange password, or just add the machine to the domain (preferred), but is there another way.
0
 
ilantzCommented:
just add him to the domain , much better for everyone :)
0
 
dexterhomeAuthor Commented:
Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.