Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 746
  • Last Modified:

allowDefinition='MachineToApplication' error in Web.Config in WWWROOT Folder

I keep getting the below error from my web.config file.

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

It points to the line:

<authentication mode="Forms"/>

I originally had my web.config file under the site root (one above the WWWROOT folder) and this error didn't occur, however the site wouldn't load either. When I move the config file to the WWWROOT, the site loads but I keep getting this error. I can't configure the WWWROOT folder as an application.

I have a feeling I have something set up incorrectly. Any ideas?
<authentication mode="Forms"/>

Open in new window

0
iammrkcohen
Asked:
iammrkcohen
3 Solutions
 
spprivateCommented:
Check the last part of this post

http://forums.asp.net/p/769696/2665116.aspx
0
 
CodeCruiserCommented:
If you are uploading your website to a hosting provider, most hosting providers allow you to create ASP.NET applications with IIS through the control panel. It is usually called "Application Settings". You can select the folder where your asp.net files reside and create that folder as an application (virtual directory) inside IIS.
0
 
iammrkcohenAuthor Commented:
Yea it actually is configured as an application. I forgot to mention that.
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now