• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 296
  • Last Modified:

MS Exchange 2007 - multiple nics

I have a single MS Exchange 2007 server runninbg with all roles (no Edge server). The server has multiple nics. How do I force outgoing SMTP to use a specific nic?
0
michaelwmorgan
Asked:
michaelwmorgan
1 Solution
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Best is not to have multiple nics in exchange, unless it is sbs. It will only confuse exchange and will cause lots of bad behaviour.

Why do you need multiple nics anyway?

Rajith.
0
 
shahsejalCommented:
Set-SendConnector
http://technet.microsoft.com/en-us/library/aa998294.aspx

SourceIPAddress
This parameter specifies the local IP address to use as the endpoint for an SMTP connection to a remote messaging server. The default IP address is 0.0.0.0. This value tells the server to use any available local IP address. This parameter is only valid for Send connectors that are configured on Edge Transport servers.

So ideally this should be done on the Edge Transport server only, but you may try it on Hub Transport by running the command, if it helps:
Set-send Connector "Send Connector name" -SourceIPAddress "the Local IP address which you want to specify"
Restart the Transport Service.

In case it does not help you may change it back by running the same command but with IP = 0.0.0.0
0
 
michaelwmorganAuthor Commented:
Mnay thanks. This appears to work perfectly.
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

Tackle projects and never again get stuck behind a technical roadblock.
Join Now