Solved

Server 2008 NTFS Permissions

Posted on 2009-05-05
4
848 Views
Last Modified: 2012-05-06
I have two issues; Im building a 2008 file server,
1.      The issue is in 2008, I've created a new drive and the permissions are; creator owner, everyone, systems, administrators, users (server).  When I remove the users and everyone, I can longer get into the folder, permission is denied, though I'm a domain admin and yes the domain admin is in the servers local admin group.  
2.      I dont mind inheriting permissions, but I want to be able to copy over permissions and then remove those users/groups I do not want, but I dont see anyway.
0
Comment
Question by:Puke Foo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 58

Accepted Solution

by:
tigermatt earned 500 total points
ID: 24307992

> #1

This is by design. In your 'normal' user token (before having elevated at a UAC prompt) you do not have any Administrator privileges. Therefore, the Administrator group does not apply, and you are denied access.

If you elevate a UAC prompt or run a program as Administrator, that is the only time you have true Admin privileges on your account and will have access to the drive.

Currently, this is a known issue with Windows Server 2008 and NTFS file permissions. At present, the only way around this is to make the user a member of another, custom group which has the permissions assigned on the drive. This will give you access to the drive without elevating at UAC.

> #2

I'm not too sure what you're talking about. If you need to copy files between servers/shares and retain their NTFS permissions, look at the robocopy tool with the /COPYALL switch.

-Matt
0
 

Author Comment

by:Puke Foo
ID: 24308703
The first answer is perfect, thank you.  

The second, I'm referring to server 2003, if I choice to not inherent permissions I can uncheck "allow inheritable from the parent to propagate etc..." then I get the option of copy or remove.  I choice copy and then remove the group/users or add the groups/users I want.  I don't seem to be able to accomplish this.  I can't choose to remove inheritable permissions, anyone know how?
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24318393

So to clarify matters, if you uncheck the inherit option, and you press 'Remove', no permissions are removed?

-Matt
0
 

Author Comment

by:Puke Foo
ID: 24453096
I've figured it out with your help thanks tigermatt
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question