Windows 7 and Wireless Networking

Hi guys
This one has got me really stumped.

I've just installed Windows 7 64 bit. Good times.
Now my Belkin Wireless G card wont work. Bad times.

The thing is, it does kinda work which is so agrivating! W7 installed its own drivers, looked like it was gunna work perfect. I can scan for networks, brilliant. I select my network, it acknowledges that there is encryption and asks for the key, I type it in and instantly it fails.

There is an unprotected network in my area, when I try to connect to that it instantly fails that too.

So, I get out one of my old USB wireless adapters and try with that, W7 goes its way and gets it all installed. I look for my network, select it, type the password, BAM. Failed again!

I can boot into XP and verify that both devices are in working order.

What has me really stumped is the fact they both can scan, both can see the networks, yet neither can connect to any networks at all.

I dont know whether this is a device issue or W7 issue but I'd really appriciate your feedback on your theories on how to fix it!
And if you need any more info, please just ask and I try and find it for you!
Thanks for reading!

Devices
Belkin PCI Wiress G Card (might be G+, dont have the box!)
No make Mini Wireless Adapter.
error.png
device.png
LVL 1
R0y4LAsked:
Who is Participating?
 
tenaj-207Connect With a Mentor Commented:
If you want to try the 32bit driver, which you should if you have the Wireless G+ card, then you'll need to download and install Win7 32bit to get it to work.

If you do call Belkin tell them your using Vista 64bit edition.  It's the same steps for all the diagnostics and trouble shooting as Win7, but if you tell them you're using Win7 then they'll tell you it's not supported and to go away.  Of course I'm guessing that's what they'll tell you for Vista too, but you have a better chance with Vista then with Win7.

I would suggest a new card, here's a list from Newegg with many cheap cards under and around $20.
http://www.newegg.com/Product/ProductList.aspx?Submit=ENE&N=40000031&Description=PCI%20wireless&name=Wireless%20Adapters&ActiveSearchResult=True
0
 
alecg13Commented:
You might have to manually install the WIFI adapter drivers manually. These usually come on a cd with the adapter or you can download them on the internet. If this doen't work you might want to send Microsoft a bug report and they might be able to send you some kind of update.

Hope this Helps!
0
 
tenaj-207Commented:
Download the Vista 64bit driver and install it with that.

Can you connect to the unsecured wireless from you XP OS?  Try turning off encryption on your own wireless and try to connect to that.

Are you using RC1 or the beta, you can download the RC here, http://technet.microsoft.com/en-us/evalcenter/dd353205.aspx.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Blizz127Commented:
Could just be a windows 7 driver issue.  AS tenaj said just download and install the vista 64 bit driver and install it manually.
0
 
tenaj-207Commented:
I found Belkins site to be slower than mud but here's the links for the drivers.

Link to Wireless G
http://www.belkin.com/support/article/?lid=en&pid=F5D7000&aid=6001&scid=221

Link to Wireless G Plus (no 64bit driver)
http://www.belkin.com/support/article/?lid=en&pid=F5D7001&aid=5426&scid=221
0
 
Raver87Commented:
If you are still running the Beta, you've found the problem. Then download the RC that was released just a few days ago.
If you have the RC, the my first thought is the same as Blizz127.
Have you tried to mail the manufacter of the cards?
0
 
R0y4LAuthor Commented:
Thanks for the great response everyone.
I've tried all your suggestions and I'm sad to say I'm still in the same position as I was at the start.
I have used Windows 7 x64 Beta 7048 and Windows 7 x64 RC 7100.

I will try to contact Belkin like Raver87 suggested and hopefully they'll have a solution!
And in response to Tenaj-207 when running XP it works fine, any network will connect and has a good quality connection with or without encryption.


I am going to try the 32 bit variant and I let you all know how I get on, it's hardly a solution but it feels like I've exhausted every suggestion Ive found searching the web so far.

Thanks again!
0
 
R0y4LAuthor Commented:
Well, I'm writing this from Windows 7 x86 connected to the internet through my Belkin Wireless Card!
I guess theres something up with the wireless drivers for 64bit!
Thanks for your help =)
0
 
R0y4LAuthor Commented:
You need to use Win7 x86 for the card to work but this solution provided me with good alternatives.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.