Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

GPOs not updating settings and GPUPDATE not completed in expected time

Avatar of drewdat
drewdat asked on
Windows Server 2003Active DirectoryOS Security
17 Comments1 Solution7118 ViewsLast Modified:
I'm having a few different issues with my GPOs and I'm not sure if they are related or not.  I have a domain with two Windows 2003 R2 Ent. DCs and approximately 75 PCs.  I've never noticed issues with my GPOs until recently when I wanted to push out some changes to the Windows Firewall.  The majority of my PCs are Windows XP SP3.  When I run gpresult it shows that the correct policy is being applied and when I run rsop.msc I find the correct settings for the firewall.  However, when I open up Windows Firewall, the changes haven't been made.  

While I was testing this, I tried running gpupdate and found that on the XP PCs it times out with:
   User Policy Refresh has not completed in the expected time. Exiting...
   User Policy Refresh has completed.
   Computer Policy Refresh has not completed in the expected time. Exiting...
   Computer Policy Refresh has completed.

I placed a test PC and user in an OU that only has one applied GPO (default domain policy which includes both user and computer settings).  When I run gpupdate /target:user it completes successfully but /target:computer times out.

I'm not sure if these two are related.  I'm more concerned about not being able to change the Firewall settings with a GPO.

Any help is appreciated. Thanks.
ASKER CERTIFIED SOLUTION
Avatar of DataBitz
DataBitzFlag of New Zealand image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 17 Comments.
See Answers