• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1108
  • Last Modified:

Blackberry Enterprise Server for Microsoft Exchange 4.1.6 MR4 Bundle 105 no longer working

My Blackberry Enterprise Server for Microsoft Exchange 4.1.6 MR4 Bundle 105 running on Windows 2003 has stopped working.  I get the following Event ID messages # 20185 #20301 #20265 and #20222.  For the user trying to get BB messages.  I made a permissions change yesterday on the inetsrv folder, around 12 noon,  it stopped working around 3 pm.  I have put the permissions back to the way they were and rebooted,  but I still get these same error messages and nothing is going through.  I personally dont know a thing about BB servers, this was dumped on me because the BB engineer is gone.  I only made the permission changes because it was left as an instruction to do.  Anyway, like I said the permissions are restored to their original state and a reboot was done,  and I still am getting these errors and no BB mail is flowing.  Any ideas where to start with this?
0
SigelC
Asked:
SigelC
  • 6
  • 3
  • 3
  • +1
3 Solutions
 
SysExpertCommented:
If you are not familiar with BES, I would call for support.

0
 
hottipsCommented:
this is happening to our server too. a reboot of the server fixes it for a short amount of time, then it starts again.


the main errors I am ggeting are events 20185 and 20265

the last 20301 errors I see are about a month ago and I have no 20222 errors. will let you know what I find.





0
 
hottipsCommented:
it turned out resetting the sendas permissions on users resolved this for me. Maybe a windows update reset permissions ?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
SigelCAuthor Commented:
we have done a number of updates on it lately,  where do I find the sendas permissions?
0
 
SigelCAuthor Commented:
The BB server is sending intermittant mail now...
0
 
Gary CutriData & Communications SpecialistCommented:
Hi, first open windows services and ensure all the BlackBerry Services are started.  As Exchange System Manager uses IIS making change to the inetsrv folder may have caused an issue.  If Exchange System Manager has an issue then BES may have issues connecting to Exchange.  If possible go to the command prompt on the BES and navigate to c:\Program Files\Research In Motion\BlackBerry Enterprise Server\Utility and run IEMSTest.exe and using the BlackBerryServer profile select a BlackBerry user.  This will run a test to see if the BES can connect to Excahnge.
0
 
SigelCAuthor Commented:
Great, this test worked yesterday when I tried it, now today it does not work...the problem seems to be getting worse...I get this error when I do this.....

C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Utility>IEmSTes
t.exe
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - EPT-BBERRY.
OpenEntry failed for user chosen from Address Book (80040107).

I am still getting the same series of message being thrown in the event viewer.  I checked the SQL server that is the back end to this,  it does not appear to have any issues, so right now, its the connection to Exchange where I need to start I am guessing.
0
 
Gary CutriData & Communications SpecialistCommented:
Are you confident that nothing has been changed on Exchange and no one has recently installed BES updates? This issue may also be cause by corrupt a BlackBerry MAPI profile but please restart the BES again and ensure all the service start after the reboot.
0
 
SigelCAuthor Commented:
Ha,  I need to double check the Exchange but I dont believe there have been any updates on it.  What I do know is that our BES server is a WSUS client, and had updates installed on it according to the logs right about the time that it started throwing the errors.  Right now it is working intermittantly, and if I reboot it, it works for about 30 seconds and then stops working again.  Throwing all those same type errors that it cannot open the users mailbox and such.  
0
 
Gary CutriData & Communications SpecialistCommented:
The error "OpenEntry failed" indicates that the BES is unable to connect to Exchange (with numerous causes).  Please make sure that the public folder store is mounted on Exchange and on the BES open Exchange System Manager to see it the Exchange server and mail stores appear accessible.
0
 
hottipsCommented:
also check, is the user its happening to a domain administrator ? windows will reset send as permissions on protected accounts.
0
 
SigelCAuthor Commented:
This is a test machine so there is only one user on it,  and it he is a domain administrator....the last 24 hours he has gotten a bunch of messages at 4:20 yesterday then it stops,  he got a bunch more at 9:54pm last night then it stopped,  he got a message at 1:05am this morning then it stopped and then again at 5:14 am and now it has stopped again......
0
 
SysExpertCommented:
SOunds as if the sendas is messed up. This generally happens for Domain admins


see
http://www.experts-exchange.com/Software/Internet_Email/Email/Email_Clients/Q__24298514.html


0
 
SigelCAuthor Commented:
Thanks..
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 6
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now