Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1507
  • Last Modified:

Cisco Unity Issue External Calls not routing to Voice Mail

We have Cisco Unity 4.0 and recently when external callers leave a voicemail the voicemail does not get routed to the recipient. We get the below error in the application event log. Intenal callers voicemails do get routed to the recipient. Does anyone know why the internal voicemail gets routed and not the external ones.

to recipient <<recipient.name>> could not be delivered and was moved to the failed directory.  This can occur for several reasons: the recipient mailbox may be disabled or inaccessible, Cisco Unity may be having trouble connecting with the partner server, or the Cisco Unity messaging component may not be properly configured.  If this condition persists, contact Cisco TAC. 0x00001024

0
illfusion82
Asked:
illfusion82
  • 2
1 Solution
 
voipmanCommented:
Run the Permissions Wizard while you select the Containers/OUs that contain Cisco Unity subscribers on all Cisco Unity servers. This selection is made when the Permissions Wizard prompts you for where you want to create/import Cisco Unity subscribers. In addition to setting Add/Modify rights for the directory service account, the Permissions Wizard should also enable the Send As/Receive As permissions for the messaging account. Now, restart the AvUMRSyncSvr service.

Note:  In order to recover and send the failed messsages to respective subscribers, you need to move the voicemail messages from the UnityMTA\Failed folder to UnityMTA folder before you restart the AvUMRSyncSv service.

Verify that the Unity_<ServerName> exists in the Active Directory Users and Computers container you specified during the installation of Cisco Unity as the container for your Cisco Unity Subscribers. V by Run Permissions Wizard and point the permissions Wizard to that container in order to verify that your Cisco Unity accounts have the correct rights and permissions over that container. Refer to Verify the Unity_<ServerName> Account is in Active Directory for more information.

If you reset the permissions in AD, this can also resolve the issue. Refer to Setting Permissions on Active Directory Containers Used for Importing Subscribers for more information on how to set the appropriate permissions.

0
 
illfusion82Author Commented:
I have tried all that and we still can not receive voice mail from external callers, only internal callers.
0
 
illfusion82Author Commented:
Hi voipman; thanks for your help. I have figured it out, there was a recent update that Microsoft rolled out for the Exchange server that caused the initial issue. I have ran the permission wizard and restarted all the Unity services; this fixed our issue.

Thanks again voipman!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now