Solved

Strange MTU size on Cisco Catalyst Express 520

Posted on 2009-05-05
9
1,551 Views
Last Modified: 2012-05-06
We are currently having problems with a transparent wireless bridge between a UC520 and CE520.  After having two of the four wireless units replaced and the problem still existing, we are now digging deeper into the switch/router configuration at either side.

The current set up is a UC520 at one site, two Tranzeo wireless bridges with a switch between them, and then finally a CE520 at another site.  The two Cisco devices are set up as a 802.1Q trunk, with 3 VLans (one for each site + management traffic (1 + 2), and voice (100)).

Everything works fine most of the time, but between around 2 to 5 times per day, the wireless link between the sites appears to go down, or at least stop forwarding traffic.  This lasts approximately 1 - 3 minutes and appears to be happening at random times.  The link restores itself without intervention.

Users notice loss of connectivity to resources, IP Phones often lose registration, spanning-tree events can be seen as root elections take place following the loss of connectivity.  

I have noticed a strange MTU setting on the Catalyst Express 520, all the other devices are using an MTU of 1500, but the CE520 gives this output :-

Command was: show system mtu
System MTU size is 1998 bytes
System Jumbo MTU size is 1998 bytes
Routing MTU size is 1998 bytes

It is my understanding that the MTU should be set to 1500 (and the Cisco Output Interpreter also suggests this is the case).  After doing some research, I found a document which says on this device it is not possible to change the MTU "from the default of 1500" (and set system mtu gives invalid command error).

Why is the device reporting 1998 and not 1500 when the document says the (unchangeable) default is 1500?
Is there in fact a way to change this to 1500?
Is this MTU setting likely to be causing the issue?
Any ideas on what else could be the cause if this is not the problem?

Thanks in advance.
0
Comment
Question by:SynergyAssoc
  • 4
  • 3
  • 2
9 Comments
 
LVL 57

Expert Comment

by:giltjr
ID: 24310610
Not sure if your switch is included in this but:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_configuration_example09186a008010edab.shtml

I think the 1998 includes overhead for various thinks like trunking, ISL, etherchannels, ect.
0
 

Author Comment

by:SynergyAssoc
ID: 24312107
I'm still not understanding why the Catalyst Express is stuck with an MTU of 1998 when all the other devices are happy with 1500?

The link you suggest is the one I was getting my information from in the original post.  We have an Express 520, so I would *assume* that the information for the Catalyst Express 500 would be the closest match, and it clearly says:

""Catalyst 2940 / Catalyst Express 500 Series
The System MTU can only be set to 1500 bytes, the default. You cannot set the MTU on a per-interface basis."
0
 
LVL 57

Expert Comment

by:giltjr
ID: 24313484
The MTU size will have nothing to do with your problem.  All that means is that the switch will support frames up to 1998.  The extra bytes are for things that are used when using VLAN's, trunks, and MPLS.  

As long as nothing uses MTU's larger than 1500 on your network, you have nothing to worry about.

What I would check is to make sure that all switch ports that are not trunks (that is they do not need to carry tagged VLAN traffic) are configured as access mode ports.

How far apart are the two wireless bridges?
0
 
LVL 10

Expert Comment

by:lanboyo
ID: 24313497
You can change the the system mtu with the system mtu command. 1998 is the maximum on your switch. System mtus can be higher than 1500 in case the ddevive is being used for QinQ trunk carying or MPLS where entire ethernet frames are carried within other ethernet frames. This can be repeated several times, so sometimes higher than 1500 is necessarry. I see no harm or advantage in dropping it, but don't think this will help your wireless problem...
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:SynergyAssoc
ID: 24313773
Thanks for the input so far.

I agree that the MTU is most likely not the cause, however i'm now at the stage of trying to rule out any possibility.  I cannot think of anything that would be using an MTU of higher than 1500 on the network, and have also tried sending oversized packets across the wireless link with the DF bit set to see if it caused any problems... nothing.

The link is not far at all, less than 1KM, just across the street in fact.  There is no direct line of sight, so we are using two seperate pairs of bridge to get from one site to the other.  Originally the two bridges were directly connected via ethernet, but since the problem occured we have added a switch in between the two bridges, but it hasn't changed the behaviour at all.

I have the trunk plugged into FastEthernet 0/1/8 on the UC520, and GigabitEthernet 1 on the CE520, as described in the quick start guide.  I am guessing normally the two devices would be sitting in the same rack, connected via Ethernet.  Is there any special configuration that needs to be considered to make this work optimally over wireless?

Because this is happening randomly for what (recently) seems to be the maximum of about a minute, I am still finding it hard not to point my finger at the wireless connection between sites, but welcome any other ideas as to the cause of the problem.
0
 
LVL 10

Expert Comment

by:lanboyo
ID: 24313775
I don't know what model Tranzeo you have, but if there was any way to get it to send system logs that you could correlate to they wifi drops, it would help a lot.

For intermittant issues on a link I have found that running an application like whats up gold, or something home brewed that can regularly poll and detect connectivity with each of the elements of the link. (Switch,wireless bridge, wireless bridge,switch) is very useful.

The problem I have had with wifi bridges is that local wifi access pints were prone to disrupt the signal intermittently. This is not to say that this is your issue...
0
 
LVL 57

Accepted Solution

by:
giltjr earned 500 total points
ID: 24313900
The switch to switch communication over a trunk port will use frames bigger than 1500 bytes.   So although the desktops and severs might not be sending out things larger than 1500 anything with a tagged VLAN packet is.

Um, 1KM is about 3200 feet, that is fairly far.  What is the speed on the wireless connection?  Since you have one VOIP VLAN, I would assume that means you are switching/bridging the VOIP traffic over the wireless connection.  You could be exceeding the bandwidth and causing what appears to be drop outs.   Even for the routed traffic between the two locations, if exceed the bandwidth you could see problems like this.


0
 

Author Comment

by:SynergyAssoc
ID: 24314020
Sorry, tHe link is considerably *less than* 1KM - it is just across the street.  I described it as less than 1KM, as 1KM seems to be the minimum distance you can configure on the wireless devices themselves.

The Wireless is using the 5Ghz band.  There are three Vlans traveling over the wireless in the trunk, two data VLans and the voice.  We have done all possible to minimise the data travelling across the link, e.g. installing a local DFS server for access to files on a shared drive.

I do not believe the issue is at all bandwidth related - looking at SNMP statistics of each wireless device, the data travelling across the link for the majority of the time is extremely low, there is no degradation of voice call before dropping, and we have also used the TTCP utility to max out the link usage even whilst the network has been being used, and there is no problem caused from this.
0
 

Author Closing Comment

by:SynergyAssoc
ID: 31578280
Thanks for your assistance.  Much appreciated.

We are still working on the bigger issue of the link going down, however, as this question was more regarding the MTU size I will create a more relevent question and close this one.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco Routing with 2 ISP connection 5 49
Droid 4 15 66
Best sims for HP switches 4 31
How often can a passive RFID be polled? 10 50
Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now