Solved

Erwin Configuration Problem

Posted on 2009-05-05
4
6,293 Views
Last Modified: 2013-12-18
Hi,

I have ERWIN installed but I cannot connect to Oracle databases. Specifically, I've tried to connect to an Oracle DB 10g DB on Linux and an Oracle Express 10g DB on Windows XP
I get same error every time:
   
     "ORA-01041: internal error, hostdef extension doesn't exist"

Any help would be greatly appreciated. See attachment for screen I'm trying to use in ERWIN and the error message dialog.

I've tried every ERWIN permutation possible to connect to DB including:
Service Name (DBATST)
Server Name
Server Name + Port
Fully Qualified Server Name (i.e. server.domain.com)
Fully Qualified Server Name + Port (server.domain.com:port)
Schema + Server Name (schema@server)
Schema + Server Name + Port (schema@server:port)
Schema + Fully Qualified Server Name + Port (schema@server.domain.com:port)
Nothing Works!  Same error every time:

MY SYSTEM
-----------
AllFusion ERWIN Data Modeler Release: 7.2.0.1644
Windows XP Professional SP3
Toad for Oracle
Oracle Client: 10.2
Document4.doc
0
Comment
Question by:deckard666
  • 2
  • 2
4 Comments
 
LVL 40

Expert Comment

by:mrjoltcola
Comment Utility
Can you connect via Toad with that user?
Can you connect via SQLPLUS with that user?
Are you connecting through a firewall?
Can you check the alert log?

ORA-0600 and ORA-01041 (internal errors) are often Oracle bugs and/or environment configuration problems and should be reported to Oracle.

You can try restarting the database to see if it clears up.
0
 

Author Comment

by:deckard666
Comment Utility
We can connect via Toad, but only direct... not TNS. We can't get TNS to work with Toad.
No firewall.
0
 
LVL 40

Accepted Solution

by:
mrjoltcola earned 500 total points
Comment Utility
From my experience using ERwin I always and only connected with TNS, I don't believe it can connect direct like recent versions of Toad can, however, I might be wrong as I switched to ER/Studio 2 yrs ago and didn't use 7.1-7.2 very long.

You should configure your tnsnames.ora with netca, or setup tnsnames.ora properly, so that tnsping and sqlplus will work with the TNS alias before trying ERwin.

Running without tnsnames.ora is atypical.

Try this below, copy into your {ORACLE_HOME}/network/admin

Then try tnsping dbatst
If that works, try ERwin again
# tnsnames.ora

#

DBATST =

  (DESCRIPTION =

    (ADDRESS_LIST =

      (ADDRESS = (PROTOCOL = TCP)(HOST = server.domain.com)(PORT = 1521))

    )

    (CONNECT_DATA =

      (SERVICE_NAME = DBATST)

    )

  )

Open in new window

0
 

Author Closing Comment

by:deckard666
Comment Utility
The solution helped us to fix the TNS problem
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

This article explains all about SQL Server Piecemeal Restore with examples in step by step manner.
Many companies are looking to get out of the datacenter business and to services like Microsoft Azure to provide Infrastructure as a Service (IaaS) solutions for legacy client server workloads, rather than continuing to make capital investments in h…
Via a live example, show how to take different types of Oracle backups using RMAN.
This video shows how to recover a database from a user managed backup

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now