Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

RPC over HTTP Outlook 2007 Exchange 2003

Posted on 2009-05-05
10
Medium Priority
?
625 Views
Last Modified: 2012-06-27
I use Outlook 2007 with Exchange 2003 SP2, and yesterday RPC over HTTP just stopped working all of a sudden.  I started getting Security Alerts for autodiscover, pointing to myregisteredsite.com.  So I changed our DNS so there were no wildcards thinking this would help.  I even removed the split-DNS our server was using just to see if it made a difference, but it hasn't helped.  The server is SBS Standard with SP2.

I've run the Internet Connection Wizard several times, removed and replaced the Outlook profile, removed and replaced the cert, which is a 3rd party cert from GoDaddy, and I get as far as /rpcdiag showing the Directory connecting fine with HTTPS but the Mail or Public Folders not showing up at all.

What could have happened to cause this mess?
0
Comment
Question by:Michael S
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
10 Comments
 
LVL 2

Expert Comment

by:Dave_Angel_Portsmouth
ID: 24311905
When you browse to the exchange server, can you get to web outlook without any certificate errors?
0
 
LVL 2

Expert Comment

by:Debug-Exchange
ID: 24312326
Hi,
Please use the tool www.testexchangeconnectivity.com and check where is it stoping
i belive it is stoping to connect with the global catalog server
1.Please check this registery entry on the global catalog server if it is not there please add it and reboot the Global catalog server
HKLM\System\CurrentControlSet\Services\NTDS\Parameters
-- Type: REG_MULTI_SZ
-- Name: NSPI interface protocol sequences
-- Value: ncacn_http:6004
2. "Configure ValidPorts registry key: on the CAS server
                       - HKLM\Software\Microsoft\RPC\RPCProxy
                       -- Type: REG_SZ
                       -- Name: ValidPorts
                       -- Value: cv-mail: 6001-6002;cv-mail.civicventures.org:6001-6002; cv-mail:6004;cv- mail.civicventures.org:6004
0
 
LVL 6

Author Comment

by:Michael S
ID: 24314729
Yes, I can pull up OWA without any cert errors.

All of my registry entries are correct.  As I mentioned, everything was working fine for almost a year, then it just stopped this past Monday.  Nothing on the server has changed, nothing on my Outlook has changed - just whammo.

On the test site, I'm assuming I'm using the Outlook 2003 test even though I'm using Outlook 2007 because I'm not using Exchange 2007?  It fails pinging 6001, even though the registry entries are correct under the Rpcproxy key.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 6

Author Comment

by:Michael S
ID: 24338213
Just an addendum - When I do the same launch of Outlook 2007 from my home PC, with the exact same setup, it prompts for a username and password, meaning it's actually contacting the Virtual folders in IIS I'm assuming?  Once I log in, it just shows as Disconnected down at the bottom.  Again, RPCDIAG shows 4 or 5 connections to Directory as HTTPS, but no Mail or Public Folder connections.

Upon testing within the environment with RPCDIAG, all connections are made but show up as TCP/IP and not HTTPS.

Then I tried using www.testexchangeconnectivity.com and it comes back saying it failed on the certificate, HOWEVER, the failure is not on the cert name, but on the trust, and comes back with the error "The certificate chain has errors, Chain status = PartialChain ".
0
 
LVL 6

Author Comment

by:Michael S
ID: 24361003
Ok, after further testing, I went to look at the IIS logs and noticed that all of the RPC_IN_DATA and RPC_OUT_DATA showed successful connections, ending with the 200 0 0 on ports 593, 6001, and 6002.  However, there are no 6004 connections anywhere to be found.  So I went and double checked the port assignments in the registry, and unfortunately they are all set correctly for the server netbios name, the server fqdn, and the outside proxy fqdn.
0
 
LVL 1

Expert Comment

by:dscott22099
ID: 24385272
I am also getting the same error from testexchangeconnectivity, and am also using Go-Daddy certificate.  I get no errors from the certificates as well.  Autodiscover stopped working.  Manual configure does work though for Outlook Anywhere.
This seems to be an issue with GoDaddy certificates, but for the life of me I cannot find out why.  
0
 
LVL 2

Expert Comment

by:Debug-Exchange
ID: 24385637
Hi,
it looks like the certificate does not have any problem
Set-OutlookProvider expr -CertPrincipalName msstd:owaurl

manuelly create the profile and make sure you dont put the MSSTD value under the moresetting - connection tab
0
 

Expert Comment

by:rg-x
ID: 24539066
We have Vista clients where Outlook fails to connect after installing Office 2007 SP2.
Either of the following 2 MS hotfixes may remedy this.

kb 933493

kb 968858

rg
0
 
LVL 1

Accepted Solution

by:
dscott22099 earned 2000 total points
ID: 24540078
The hotfix from http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=968858&kbln=en-us fixed my situation.  I was not able to use autoconfigure from outside the network.  Applied the hotfix, and it works again.
0

Featured Post

Tech or Treat! - Giveaway

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question