Could not access Jsp pages behid ISA 2006

Dear All,
 
I have ISA 2006 configured as a firewall, I have some websites that works for direct internet users and does not working for ISA users, I tried the following.
- Install firewall client . Failed
- Configure direct site access as per Ms articles. Failed
- create a firewall rule from internal  to these sites. Failed

please tell me how to fix this problem.


Thanks
LVL 1
ITMaster1979Asked:
Who is Participating?
 
Raj-GTConnect With a Mentor Systems EngineerCommented:
1. Do you  have all the updates installed on your ISA Server? http://technet.microsoft.com/en-us/forefront/edgesecurity/bb734854.aspx
2. Do you see any compression errors on the Event Logs of the ISA Server?
3. Use the monitoring tab of the ISA Server and export the logs here.
0
 
BembiConnect With a Mentor CEOCommented:
There are several options, why ISA may block these sites. What I have seen is mostly, that such sites have some programmatical issues, especially if only a few sites are affected.

In normal cases, ISA should show all kinds of pages (including java or php or whatever), by default.

Best method is ( as Raj-GT said) so enable a monitor definition, which logs the traffic from your test machine (faulting jsp) to the internet. If ISA is blocking something by a rule, you should see something there (includig the affected rule).

So my checklist would be (Secure NAT client assumed).
(Make sure, you can reset all changes !!!)

If this is a general problem:
- Right click your rule, which allows web traffic - properties
- Check "Content types" if there is something denied.
- Click on toolbox (right pane) - content types - Applications - tab "content types
--> you should find .jsp within the list.

If this is a problem with only a few sites:
- Right click your rule, which allows web traffic - configure HTTP
- Try to play around with:
---> tab General --> verify normalisation and block high bit characters
---> tab methods and tab extensions if there is something blocked
---> tab headers ist there is something non default

- Right click your rule, which allows web traffic - configure RPC protocol --> disable strict RPC

An issue maybe also HTTP compression (disable it)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.