Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Could not access Jsp pages behid ISA 2006

Posted on 2009-05-05
3
Medium Priority
?
896 Views
Last Modified: 2012-06-21
Dear All,
 
I have ISA 2006 configured as a firewall, I have some websites that works for direct internet users and does not working for ISA users, I tried the following.
- Install firewall client . Failed
- Configure direct site access as per Ms articles. Failed
- create a firewall rule from internal  to these sites. Failed

please tell me how to fix this problem.


Thanks
0
Comment
Question by:ITMaster1979
3 Comments
 
LVL 15

Accepted Solution

by:
Raj-GT earned 500 total points
ID: 24312375
1. Do you  have all the updates installed on your ISA Server? http://technet.microsoft.com/en-us/forefront/edgesecurity/bb734854.aspx
2. Do you see any compression errors on the Event Logs of the ISA Server?
3. Use the monitoring tab of the ISA Server and export the logs here.
0
 
LVL 35

Assisted Solution

by:Bembi
Bembi earned 500 total points
ID: 24319011
There are several options, why ISA may block these sites. What I have seen is mostly, that such sites have some programmatical issues, especially if only a few sites are affected.

In normal cases, ISA should show all kinds of pages (including java or php or whatever), by default.

Best method is ( as Raj-GT said) so enable a monitor definition, which logs the traffic from your test machine (faulting jsp) to the internet. If ISA is blocking something by a rule, you should see something there (includig the affected rule).

So my checklist would be (Secure NAT client assumed).
(Make sure, you can reset all changes !!!)

If this is a general problem:
- Right click your rule, which allows web traffic - properties
- Check "Content types" if there is something denied.
- Click on toolbox (right pane) - content types - Applications - tab "content types
--> you should find .jsp within the list.

If this is a problem with only a few sites:
- Right click your rule, which allows web traffic - configure HTTP
- Try to play around with:
---> tab General --> verify normalisation and block high bit characters
---> tab methods and tab extensions if there is something blocked
---> tab headers ist there is something non default

- Right click your rule, which allows web traffic - configure RPC protocol --> disable strict RPC

An issue maybe also HTTP compression (disable it)
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Several part series to implement Internet Explorer 11 Enterprise Mode
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…
Suggested Courses
Course of the Month10 days, 23 hours left to enroll

886 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question