USB flash disks not getting drive letter

Hi all,
        From last two weeks whenever I insert a USB flash disk into my laptop it doesnot show up in the "My Computer". It connects properly and makes the connection sound and the green "Safely remove  USB mass storage" icon appears in the Notification area. Also in the Device Manager under "Universal Serial Bus Controllers"  I can see the USB mass storage device but without any drive letter assignment.

Diagnostic Steps taken so far:

1) Checked the USB device on other PC and it is working fine so my USB flash disk is fine.
2) Checked other USB flash disk on my laptop and it is also not recognized. (So problem is in my laptop)
3) Booted using Hiren's Boot CD/Bart PE and the USB flash disk is working fine there. ( No hardware problem in USB host controller)
So the problem seems to be in Windows. Next I googled a bit and found the following suggestions

1) Delete drivers for the "universal host controller" and "Enhanced Universal host controller" and let windows re-install them. This had no effect.
2) Assign a new Drive letter to the USB device using the Computer Management | Device Management.  But I cant see any USB device in the Device management. I can only see the DVD-Drive even when the USB is connected.
3) SPTD.SYS driver problem with Daemon tools. I have used the utility given on the website of daemon tools but nothing has changed.
4) Mapped Network Drive conflict. I have not Mapped any Network drive and when I click on the "Disconnect Network Drive" I get "You have no Drive to disconnect".
5) Using USBDLM  utility from but no effect.
So now I have run out of ideas. The only idea left is to re-install windows. Can anyone guide me in the right direction?

OS Windows XP SP3
Thinkpad T42P laptop
LVL 13
Who is Participating?
nobusConnect With a Mentor Commented:
did you try updating the chipset driver?  if not, do that first.
 this can also help :
start>run>diskmgmt.msc      check if the usb devices show up in disk management, then run :   start>run>services.msc

Download devcon :
then run :   devcon enable @usb\*

In the listing look for removable storage service.
If it is set to Auto, and not started, then start it : click the Start link in the top left...

Also, in the device manager, under Universal Serial Bus>right click each root hub, and select Properties>Power Management, and uncheck "Allow Windows to turn off this device to save power".

In c:\windows\inf, look for usbstor.inf    -  If it is not there, you can copy it from another PC..When you find it, right click it and select Install
JoWickermanConnect With a Mentor Commented:
Hi imarshad

If you insert the flash drive and the right click My computer, click on Manage, and then click on Disk Management, does the flash drive show there?

Let me know
imarshadAuthor Commented:
No the USB doesnot show up in the Disk Management
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

JoWickermanConnect With a Mentor Commented:
Ok, so you only have a Disk0?


"Run "regedit" and select the "HKEY_LOCAL_MACHINE/SYSTEM/MountedDevices" folder. See all the "Dos Devices" listed? You'll have one entry for each physically mounted drive (HDD or Disc) plus you'll have one show up for each USB drive you attempt to insert. Double click each device listed and see if you see text saying something like "U.S.B.S.T.O.R...". Once you find that device, right click it and select "Rename". Now change the drive letter to something unused... like Q: or something. Close regedit, disconnect the USB device and reconnect again."
imarshadAuthor Commented:
I can see the following for F: (which is the drive my USB disk usually got assigned)
and so on.....
I have renamed it to point to H: which is of course free but the problem persists..... So it seems that this is not the problem.

Other entries there are
\DosDevices\C:   (This is my C drive partition)
\DosDevices\D:   (This is my D drive partition)
\DosDevices\E:   (This is my CD/DVD drive)
\DosDevices\G:   (This is a virtual drive created using daemon tools)
\DosDevices\H:   (This is the Storage Removable device which earlier was F:)
imarshadAuthor Commented:
also there is another folder in the registry by the name of HKEY_LOCAL_MACHINE/SYSTEM/MountedDevices1
There is no entry for F: or H: in this folder. Can this be a problem?
usieberConnect With a Mentor Commented:

Have you Acronis TrueImage 2009 Home installed? The first version which seems to be still sold in boxes is known for causing such problems. There is an update availlable

Yes, it can be a potential problem. Add if you can.

To test, rather use a drive letter such as R.
imarshadAuthor Commented:
No I donot have or ever had Acronis True Image installed....
I have tested using the drive letter R but to no avail....
also I have created an entry for it in HKEY_LOCAL_MACHINE/SYSTEM/MountedDevices1 folder and still no success...
swift1004Connect With a Mentor Commented:
Open the device manager, expand the USB section and then plug in the USB flash disk.  See if the device pops up anywhere.  If it does, uninstall the device and let Windows reload it.  If it does not pop up, then try selecting View ... Show Hidden Devices.  If it does not show up there, then you may need to add a System Variable in the Environment Variables table.  You want to add devmgr_show_nonpresent_devices   with a value of 1.  This will let you see all the devices configured using plug and play even though they are not plugged into the laptop right now.  They will show up grayed out.  Look for any USB flash disk devices and uninstall them.  

The theory here is that you have a damaged install of the flash devices and you need to remove it before Windows can reload it correctly.  If I'm wrong, at least you can clean up all the devices that no longer use from your plug and play installations.  :)
imarshadAuthor Commented:
>>check if the usb devices show up in disk management
No I cant see the USB device in the disk management. I can only see the DVD drive over there.....
>>removable storage service
It was set to auto and not started. I started it but to no avail.
>>Universal Serial Bus>right click each root hub, and select Properties>Power Management, and uncheck "Allow
>>Windows to turn off this device to save power".

Done but still no success.

>>In c:\windows\inf, look for usbstor.inf

It was there and I again installed it but to no avail....

>>See if the device pops up anywhere.  If it does, uninstall the device and let Windows reload it.
I have done this several times. When I insert the USB device after uninstalling the driver the notification area shows "Found new hardware" and then "Kingston G2 Traveller" and then "Disk drive" and after that "Your new hardware has finished installation and is ready to be used" or something like that.
Also when I view the hidden devices I can see an entry for the USB in the Storage Volumes section by the name of Generic Volume.
nobusConnect With a Mentor Commented:
you used the same inf file for install ?  that is NOT what i asked, you must use another file
imarshadAuthor Commented:
Now I have copied it from another PC (windows XP SP3) and installed it. But still nothing shows up...
nobusConnect With a Mentor Commented:
some more to try :
Remove old hardware devices :
go to Start>right click My computer>properties>device manager
in the view tab - click : "show hidden devices"
inspect  device manager for all hidden devices, and remove them

OR :
Remove all USB drivers with:      ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:

you can also reset the usb :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usb.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbport.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbprint.inf
imarshadAuthor Commented:
Tried all of the options suggested above but still my USB stick cant get detected.
It seems that re-installing windows is the only option left.....
nobusConnect With a Mentor Commented:
yes, i'm afraid so.
imarshadAuthor Commented:
Now suddenly my USB has started working..... I dont know how but it has......
did you install software; or an upgrade ?
imarshadAuthor Commented:
No I didnot installed any new software... My Windows and IBM updates are scheduled automatically so I dont know if any new update has corrected the problem.
that can be; so - good luck with it !
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.