• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 722
  • Last Modified:

WCCP and squid

I have squid running on Its on but it seems someone disabled it on the router. How do I activate it?

I dont want it running for all out routed sites, just subnet

How do I configure this in the cisco router?

I need all http traffic to be cached on squid for this one subnet. Thanks.
1 Solution
Network_PadawanAuthor Commented:
Sorry I should have been more specific. I want to configure WCCP on the router to redirect http traffic to the cache server.
This is a simple config. Your wccp web cache needs to inform the router that it is available for cacheing. You do this by telling it the IP of the router usually.


ip wccp version 1

enables wccp version 1, version 2 is the current default.

Then you need an access list...

access-list 100 permit ip any

These are the addresses you need cacheing services for. All else does not utilize the caching service by teh default deny all.

Turn on caching service, referencing the list...

ip wccp web-cache redirect-list 100

Check the cache has registered using the show ip wccp command...

And on the outgoing interface...

interface ethernet 0
ip wccp web-cache redirect out

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now