Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 323
  • Last Modified:

VIsual WebDeveloper Keeps Using keeps using ASPNETDB.MDF Not SQL

Hi

My problem is that VWD 2008 keeps creating an app_data folder with ASPNETDB.MDF contained within it every time I start the ASP NET Configuration tool and it stores all the membership information in the  ASPNETDB.MDF database and not SQL server as I intend it too.

I have used aspnet_regsql.exe to make sure it uses SQL server for the membership and it does then create the membership tables and views in SQL but every time I use the Configuration tool in VWD 2008 it creates a new app_data folder with ASPNETDB.MDF contained within it even if i delete it.

How do I get the configuratiuon tool to use SQL and not  ASPNETDB.MDF?
0
Ed
Asked:
Ed
1 Solution
 
GuitarRichCommented:
Check your web.config file for your web application. They might look a bit like the code snippet below. Check that the connection string they are using is pointing to your SQL Server and is not the default one which will create the aspnetdb in the app_data folder.
    <roleManager enabled="true">
 
        <providers>
 
            <clear/>
 
            <add name="AspNetSqlRoleProvider" connectionStringName="MyAspNetDB" 
 
                applicationName="/SampleRolesApp" 
 
                type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
 
        </providers>
 
    </roleManager>
 
    <membership>
 
        <providers>
 
            <clear/>
 
            <add name="AspNetSqlMembershipProvider" 
 
                connectionStringName="MyAspNetDB" 
 
                enablePasswordRetrieval="false" 
 
                enablePasswordReset="true" 
 
                requiresQuestionAndAnswer="true" 
 
                applicationName="/SamplesRolesApp" 
 
                requiresUniqueEmail="false" 
 
                passwordFormat="Hashed" 
 
                maxInvalidPasswordAttempts="5" 
 
                minRequiredPasswordLength="7" 
 
                minRequiredNonalphanumericCharacters="1" 
 
                passwordAttemptWindow="10" 
 
                passwordStrengthRegularExpression=""                      
 
                type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
 
        </providers>
 
    </membership>

Open in new window

0
 
EdAuthor Commented:
it was exacly as you suggested, thanks.

problem solved
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now