?
Solved

How do I access the same login session on SBS?

Posted on 2009-05-06
8
Medium Priority
?
294 Views
Last Modified: 2013-12-05
When I remote into SBS 2000 and login as Admin (of the domain), I start a program.  If I let the connection disconnect, and then relogin as Admin again, the programs that were running are gone, it's as if I'm logging in for the first time.  If I check the processes in the Task Manager, it shows that program running, but I am unable to access it.

What can I do to access this program, and how can I re-login to the same user session?

Help!
0
Comment
Question by:wukovits
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 4

Expert Comment

by:theShao
ID: 24314914
Open "teminal Services Manager" from administrative tools, find your "old" session, right-click on it and choose "connect". By default, SBS2003 allows 2 sessions at a time, and will re-connect you to the old session if you log in from the same client (although not always). Once there's 2 running sessions, it will ask you at logon, but you can always switch from Terminal Services Manager.
0
 

Author Comment

by:wukovits
ID: 24318522
How can I switch to the session I want?  I just tried to login as Admin again, and it just added another.  I have listed:

RDP-Tcp (listener)
Console (Administrator)
RDP-Tcp#7 (Administrator)
RDP-Tcp#8 (Administrator)

I'm logging in from the same client, and I'd love to be able to logoff, and log back into the same session.  Help!
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 24318574
from a command prompt use

mstsc and use the option /admin  or /console ( version dependent ) to access your old session

I use batch files for this.

I hope this helps !
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 77

Expert Comment

by:Rob Williams
ID: 24319994
You can set this in several places; Group policy on your domain controller, local group policy on the TS, or just under administrative tools | terminal services configuration | server settings | in the right hand window -restrict each user to one session.
However, do not log off, but rather disconnect (click x) then when reconnecting you will be rejoined to the same session.
0
 
LVL 4

Expert Comment

by:theShao
ID: 24320783
From the sessions you have listed, they work out as follows:
RDP-Tcp (listener) - This is listening for new connections, ignore this.
Console (Administrator) - This is the session logged in on the physical server, hence the "console"
RDP-Tcp#7 (Administrator) -
RDP-Tcp#8 (Administrator) - One of these two will be your "old" session, the other will be listed as "active" and is the one you're logged in on - right-click on whichever is listed as "disconnected" and click connect and you should get the session you want back. RobWill's answer will make sure you always get the same session in future.
0
 

Author Comment

by:wukovits
ID: 24327376
RobWill:  In the Terminal Services Configuration, I only see these options in the right pane of the Server Settings.

Terminal Server Mode
Delete Temporary folders on ext
Use temporary folders per session
Internet Connector licensing
Active Desktop
Permission Compatibility

There's nothing listed for "restrict each user to one session".  If looking in group policies, how can I adjust this there?

theShao:  thanks for the clarification on what those sessions refer to.

SysExpert:  Looking at the command line stuff, when I tried it, it appeared to me that it an open RDP connections from a command line, but I didn't see anywhere that I could connect to the existing login connection.

Thanks for the help thus far, and I look forward to the resolution of this question!
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 1500 total points
ID: 24327722
My apologies I missed server 2000. I don't currently have access to any 2000 servers to check.
If 2003 the group policy is:
computer configuration | administrative templates | Terminal service | restrict each user to a single session.
I don't know if a similar policy exists on 2000.
0
 
LVL 4

Expert Comment

by:theShao
ID: 24353781
The only way i've found to do this in Windows 2000 is using the LockSingleUser2.exe utility (download here: http://shaolinmonk.net/LockSingleUser2.zip) - put this in the Startup folder in your profile, and it will lock the profile so it can only have one session at a time. This means if the administrator account is logged on "locally", you won't be able to log on remotely, so ensure the account is always logged off in the office.
I've had mixed results with this utility, but it might work for you and is the only way i know of to achieve what you need.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question