Network Problems

Posted on 2009-05-06
Last Modified: 2012-06-27
I have a customer who is unabe to ping an IP address thru VPN tunnel  The VPN tunnel is up and running and shows traffic flowing between the two sites.  I have captured some packets with tcpdump on the internal interface of the FW.  I notice that there are arp reply error messages.  Does this seem to be a Layer 2 issue?

tcpdump: listening on eth1
10:49:14.330460 arcagent-adams > icmp: arcagent-adams udp port syslog unreachable [tos 0xc0]
10:49:15.339944 arp reply is-at 0:c:76:1b:b8:20
10:49:19.630313 arp reply is-at 0:1b:d3:18:98:be
10:49:20.137804 arp who-has tell
10:49:20.739895 arp reply is-at 0:11:25:e8:6f:d9
10:49:25.170102 arp reply is-at 0:d:56:f2:a4:14
10:49:26.580106 arp reply is-at 0:d:61:5e:a2:5f
10:49:29.142056 arp who-has tell
10:49:29.143180 arp who-has tell
10:49:32.140139 arp reply is-at 0:8:54:3:a3:1d
10:49:35.330048 arp reply is-at 0:d:61:80:1a:7b
10:49:37.590327 arp reply is-at 0:11:11:99:c4:64
10:49:39.580428 arp reply is-at 0:1d:92:bc:7:be
10:49:39.780125 arp reply is-at 0:c:f1:86:e5:2f
10:49:41.142391 arp who-has tell
10:49:41.145515 arp who-has tell
10:49:42.920047 arp reply is-at 0:c:f1:b6:cd:97

17 packets received by filter
0 packets dropped by kernel
Question by:hotrod_952
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +1

Expert Comment

ID: 24315182
It certainly due to a route problem. Could you tell me more about the entiere ip configurations

Author Comment

ID: 24316060
Customer mention they can access the internet but can't access a particular server through the VPN tunnel.  Other machines within the network can access the server thru VPN tunnel.  Rules are setup to allow all subnet access thru VPN tunnel.  I notice the machines that show "arp-whois" are the machines that having the issue.  I can ping the machines except from the FW.  Should I add a route on the machine or FW?

Expert Comment

ID: 24316619
what is and did you mean arp who-has?

It looks like you may have some arp caching issues either on a router / firewall or other intermediate device, or on the local host.

machine a - can ping IP address of remote server
machine b - cannot ping IP address of remote server
machine b - is on the same subnet as machine a
machine b - has unique but same ip configuration for local network interface

is this a fair characterization of your problem?  

I am going to be out of pocket for a few hours, hopefully louis can help you but if not I will look at it when I return.

Now Available: Firebox Cloud for AWS and FireboxV

Firebox Cloud brings the protection of WatchGuard’s leading Firebox UTM appliances to public cloud environments. It enables organizations to extend their security perimeter to protect business-critical assets in Amazon Web Services (AWS).


Expert Comment

ID: 24316628
Can the particular server ping the client thru vpn ?

have you tried the tracert or traceroute command from this particular server to vpn client ?

Accepted Solution

alamow earned 500 total points
ID: 24317200
From what I see you are actually saying that is not an issue in a single machine but multiple machines.  If this is the case, we already know it's not hardware because you can actually connect to the VPN.  It's not routing because those machines with the problem are able to connect to other services on the server.  If all machines are on the same network and some of then can ping the server I would suggest checking your firewall rules just in case you are not blocking ping for some machines, sometimes a lot of changes have been done on the FW and one forgets to remove things like that which drive you crazy later on.

If that is not the case, it sounds to me that you have some other FW blocking ping.  Check the server and make sure it does not has a FW and if it does disable it and test.  If the server is OK you may want to disable the FW on the machine just to test it; I really don't think the FW on the machine will do a different because the ping request is originated from that machine.

Just in case, to enable ping on your firewall you must allow this:


This allows only the required status messages to traverse the FW, others may be malicious:

Check this info for the ASA/PIX CISCO FW:

Author Comment

ID: 24325344
Also, the customer mention that they are trying to download files from an internal site at a remote location thru their VPN tunnel.  All other VPN tunnel traffic is working great.  I ran the tcpdump from the internal interface of the FW.  This is where I see the arp-who is messages.  Whenever I ran the tcpdump on the external interface of FW there where no arp-who is messages.  Any suggestions are needed.

Author Comment

ID: 24357507
This happen to be a DNS-related issue.  The DNS server needed an entry added.

Author Comment

ID: 24357537
DNS issue

Expert Comment

ID: 24360736
HR... glad you got it worked out... internal DNS?  


Author Comment

ID: 24385180

Author Closing Comment

ID: 31578468
DNS issue

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question