Disable Session Printers Citrix 4.0

I am using Citrix 4.0 presentation server. How can I disable session printers? I created a policy and set the sessions printers rule to "disabled", but the session printes keep showing up. Does this policy only affect logging in through published applications? The printers are showing up when I connect via RDP. Do I need to do this through terminal services?
estantonAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
chuckyhConnect With a Mentor Commented:
Yeah you need to disable printer mapping through TSCC.msc that I described for ICA-tcp and RDP-tcp.


0
 
NDSSICommented:
If you wan't to disable printer mapping in citrix enviromet, so users can't print you will have to turn off printer mapping. Not session printers. Session printers are printers that you wan't to map for users from your print server. If you will disable that user can't map network printers you will have to remove printer drivers for the printers, or stop print spooler. Printers that user have mapped him self in the session you can't delete by citrix policy. You will have to delete that priners from script or delte his profile.
/AJ
0
 
chuckyhCommented:
What do you mean by session printers? The printers that are mapped when you login through RDP or citrix are not session printers.  If you want to disable printer mapping through terminal services you can run tscc.msc  and right click on RDP-tcp or ICA-tcp and properties under the client session tab. You can disable printer mapping there.
0
 
estantonAuthor Commented:
I only want users to be able to print to printers that are shared out by the server they are connected to. I don't want them to be able to print to their local printers. I also don't want to waste any unnecessary resourses on the server. When I RDP into the terminal server I see my printers. They are listed as
PrinterName (from ComputerName) in session 1. I assumed these were "session" printers and were giving me the ability to print using my local printers.
0
 
estantonAuthor Commented:
Perfect. Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.