Solved

How do I configure Hummingbird BI Web Server?

Posted on 2009-05-06
4
642 Views
Last Modified: 2013-11-21
My company is using Hummingbird for some of our reporting. The software runs on the same computer we run our Anti Virus Console on. We recently upgraded to Symantec Endpoint Security. During this install, some changes were made to java and IIS, but I don't know what they are and now we cannot access Hummingbird via the web interface. Hummi was using port 80 and 443. Symantec uses somthing else (8014) I think.  I need to know how to reconfigure Hummingbird to be accessible via the web.

Thanks.
0
Comment
Question by:bbogle2007
  • 2
  • 2
4 Comments
 
LVL 22

Expert Comment

by:cj_1969
ID: 24356799
Check your AV software ... chances are it did not disable or change the config for your app.
It most likely is running interference and is blocking port 80, 443 or something else that your app needs to work.

That said, is the app running?
If this is a Java version issue then the old version should still be installed ... for that matter I don't think this would be java related.  If an application is running Java it typically installs its own version and then uses internal or localized variables to point to its own version.  BUT ... if java was a requirement and it made you install an updated version as a prerequisite to installing the app, then this is a possibility.  In which case, your old version should still be there and you just need to determine how to set a localized variable for the application to repoint JAVA_HOME to the version that it needs.

Another thing to look at ...
If the new app (version) is also using IIS on the default port 80 then it might have installed a web.config which has implimented security or restrictions that is preventing IIS from being able to serve up the hummingbird site.  If this is the case, then you could try creating a new virtual site (in a new top level directory such as c:\inetpub\www2root) and then duplicate the application site into this new high level site.
0
 

Author Comment

by:bbogle2007
ID: 24356899
I disabled everything Symantec. that didn't work. I also disabled Windows Firewall.  I checked in Add/Remove Programs and there is only one version of Java . . . 1.4.2_08, which was required by Hummingbird. When we were installing Symantec, we received a prompt to install Java, but we decided not to since we knew Hummingbird was very specific in their version.

Can you give me a little more info on the IIS solution. I'm not familiar with IIS administration at all.

Thanks
0
 
LVL 22

Accepted Solution

by:
cj_1969 earned 500 total points
ID: 24357088
Was hummingbird using IIS or its own web server?
This could be the problem if it was using its own and was using port 80/443
Those are the default ports for IIS.
If this is the case then go into the properties of IIS and change the default ports that IIS is using.
Restart IIS and hummingbird and then see if hummingbird will respond on port 80.
0
 

Author Closing Comment

by:bbogle2007
ID: 31578490
Thanks. You are the MAN!! Now I remember that when we were installing Symantec we were required to enable IIS. We originally had it disabled so that there wasn't any interference with Hummingbird. I changed the default site to use port 70 and voila.

Thanks a lot CJ.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Logparser is the smartest tool I have ever used in parsing IIS log files and there are many interesting things I wanted to share with everyone one of the  real-world  scenario from my current project. Let's get started with  scenario - How do w…
Lync server 2013 Backup Service Error ID 4049 – After File Share Migration
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now