Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2207
  • Last Modified:

Firebox proxy blocking Camera program on port 80

Need some help with a wathguard firewall. I am using the proxy server to block adult content from the internet. This is also blocking me from using a program to view the cameras in the Atlanta office. The program uses port 80 to communicate with the security camera servers. How can I block the adult content without having the cameras blocked?  I have attached a copy of the log below:

Type      Date-Time      Detailed Message      
Traffic      2009-05-06 10:54:55      ProxyDeny: HTTP Request line parse error disp=DENY, direction=OUT, pri=3, policy=HTTP-proxy-00, protocol=http/tcp, src_ip=192.168.1.52, src_port=2113, dst_ip=***.***.***.***, dst_port=80, src_ip_nat=***.***.***.***, src_port_nat=10228, dst_ip_nat=, dst_port_nat=0, src_intf=1-Trusted, dst_intf=0-External, rc=594, proxy_act=HTTP-Client.1, line=\x3c?xml version:\x221.0\x22 encoding:\x22utf-8\x22?\x3e\x3cmethodcall\x3e\x3crequestid\x3e0\x3c/requestid\x3e\x3cmethodname\x3econnect\x3c/methodname\x3e\x3cusername\x3eIT\x3c/username\x3e\x3cpassword\x3e1234\x3c/password\x3e\x3ccameraid\x3e[cam4] Camera 1\x3c/cameraid\x3e\x3calwaysstdjpeg\x3eno\x3c/alwaysstdjpeg\x3e\x3cconnectparam\x3eid:4d2882d6-096a-4951-aa1f-fa66e4a386d9\x26amp;connectiontoken:TOKEN%23210970B4-9D6A-405C-B289-2FCF55915452%23127.0.0.1%3a80%2369.38.58.105%3a80\x3c/connectparam\x3e\x3c/methodcall\x3e\x0d\x0a, tag=1006
0
ipcipher
Asked:
ipcipher
  • 3
  • 3
1 Solution
 
dpk_walCommented:
If the camera is using static IP, then add a filter HTTP service and configure as below:
Enabled and allowed; from internal-ip-of-camera; to ANY

Other than camera all traffic would be subjected to HTTP proxy.

Thank you.
0
 
ipcipherAuthor Commented:
Yes the camera is using a static ip of 69.***.***.*** and is located in the Atlanta office. I am at the Savannah office using an IP of 72.***.***.*** when I use the program i receive an error that the camera is trying to reconnect. This only happens when I have the web proxy on. The proxy is also located at the Savannah office. I am not sure what you want me to do. Can you walk me through the steps?
0
 
dpk_walCommented:
Is there a VPN tunnel between the two offices; also please provide details if you connect to the camera using public IP or private IP (through VPN) and when you see the problem.

Normally for VPN ANY service would take care of all the traffic.
If you are accessing the camera using public IP then you must have forwarded port 80 to internal IP of camera [which should be static].
Add HTTP service from the predefined group "Packet Filters"; this policy would ensure that the FB does not do any L7 processing for the packets outgoing from camera.
Configure the service as below:
Connections are enabled and allowed; from internal-ip-camera; to ANY
Also, if you are accessing the camera using public IP, and the HTTP proxy is creating problem then we would add one more HTTP policy from packet filters for inbound traffic as:
Connections are Enabled and Allowed; from ANY OR specific IP; to NAT-as-configured-on-existing-HTTP-proxy-service

Which version of WG software are you running. The steps would differ a bit based on software version.

Please update.

Thank you.
0
New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

 
ipcipherAuthor Commented:
dpk wal Thanks! I got it done. I appreciate your patients.
0
 
ipcipherAuthor Commented:
Thanks!
0
 
dpk_walCommented:
You are welcome! :)
0

Featured Post

Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now