• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 270
  • Last Modified:

Exchange 2003 Mailbox permission

I have a problem where everyone can see eveyone elses mailbox is they know how to open them in outlook.  I want to restrict this so only the administrator can open other mailboxes.  How do i do this in exchange.  the last time i did this the stores wouldnt mount and i had to call microsoft to get it fix because i screwed up the permission.
Matt Pessolano
Matt Pessolano
  • 2
1 Solution
Hypercat (Deb)Commented:
This is very complex.  The first step is to check in the Exchange System Manager and in the Active Directory Users and Computers management console to see if the Everyone group or the Authenticated Users group has been given Send As and Receive As permissions to the entire container.  Check the security settings on the ADUC Users container and also check the permissions in the ESM at the Site, Server and information store levels and post what you find in terms of the Everyone and/or Authenticated Users group.
Matt PessolanoAuthor Commented:
the everyone group under each mailbox store is greyed out and has full control and send and recieve as checked.  i cant find the everyone group in the ADUC.
Hypercat (Deb)Commented:
First, let's check the Exchange delegation settings - maybe someone delegated the Exchange Full Administrator role to the Everyone group by mistake.  In the ESM, right-click on the top-level object (the Site name) and click Delegate control.  You may get a banner page, click Next and you'll see a list of the delegations that have been made.  If you see the Everyone group there, then remove it.
This is quite simple.
The only permissions you are worried about are Send As/Receive As or Full Mailbox Access. Nothing else.
Full Control IS NOT a permission to worry about. DO not confuse permissions to the object to permissions to the content. The only two permissions that allow access to the content are the two above.

If everyone has send as/receive as then that is how the access is being granted. If it is greyed out then it is being inherited from somewhere. You need to find out where. I would suspect at the store level. Look at the properties of the mailbox store and the server itself, looking at the security tab.
If you find the permissions there, then remove JUST the Send As/Receive As. DO NOT remove the entire Everyone setting, as that will cause problems - ie lock you out of Exchange.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now