Solved

Exchange 2003 to 2007 Transistion issue with public folder and emails

Posted on 2009-05-06
10
273 Views
Last Modified: 2012-08-13
I have Exchange 2007 and 2003 up and running, but I cannot get my public folders to replicate over to exchange 2007.  I also cannot email from 2003 to 2007 mailboxes.  I looked at the exchange 2003 queue and have about messages sitting in the queue EXCHANGE2K3-EXCHANGE2K7 (Routing Group Connector).

I sense this is my issue with public folders and emailing.  How do I resolve this?
0
Comment
Question by:ohmErnie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 2

Expert Comment

by:mohammedkasim21
ID: 24317551
Hi,

May be Mail-Flow settings are not properly configured between EXCHANGE2K3-EXCHANGE2K7, please check http://technet.microsoft.com/en-us/library/bb124350.aspx

And once mailflow issue is resolved hopefully it should also resolve you Public Folder issue as well.

Mohammed Kasim
0
 
LVL 6

Expert Comment

by:ilantz
ID: 24317568
try looking for the error of why , use the queue viewer in the toolbox of 2007 , and try to get the idia of why.
run the best practice analyzer and see if it has any input on the subject , run the health test it's enough.

i also found this wierd hack to solve some issues like this , it wont do any harm anyway.

get-routinggroupconnector | set-routinggroupconnector -cost 5
restart-service msexchangetransport
and restart SMTP + MTA + Routing services in the 2003.

it could be a few reasons , lets start by checking for more info & raising the cost of the connector.

0
 
LVL 1

Author Comment

by:ohmErnie
ID: 24318263
Results of running exchange BPA:
Exchange 2007:
- Microsoft Filter Pack not installed
- Firewall is enabled (The windows firewall says off though???)
Exchange 2003:
-Smart host is set on SMTP virtual server
-Integrated Windows Authentication is turned off
-Open relay test failed
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 1

Author Comment

by:ohmErnie
ID: 24319510
I had a smart host set so I removed it because I read this could cause problems.  removing it did not resolve the problem, but I have not set it back yet.  I deleted the installed routing groups and recreated new routing groups with a cost of 5 and still experience the same issues.
I can email from 2007 to 2003, but cannot email from 2003 to 2007.  No smart host is being used currently.
0
 
LVL 65

Assisted Solution

by:Mestha
Mestha earned 100 total points
ID: 24320003
Did you fix the authentication settings?
Did you restart the SMTP Server service after changing the smart host on the SMTP virtual server?

Message Tracking will show the public folder replication traffic, including whether it was delivered to the remote server or not.

Simon.
0
 
LVL 6

Expert Comment

by:ilantz
ID: 24320108
you should not configure the smart host in the SMTP virtual server in the 2003 , configure it in the 2003 connector for the internet. http://support.microsoft.com/kb/265293 for reference.

try telnet ip_of_2007 25 , from the 2003 server to see that indeed it is able to connect to the 2007 smtp service.

double check about that bpa warning about the firewall. disable also any file level antivirus you might have on the 2007 until you'll clear things out.

good luck

0
 
LVL 1

Author Comment

by:ohmErnie
ID: 24325598
The authentication issue is in regards to exchange activesync when trying to access a mailbox on 2003.
I get a 220 when I telnet to exchange 2007, so it appears to be receiving a connection.
There is no AV installed yet on exchange 2007 and i disabled it on 2003 for testing.
I removed the smart host from the Default SMTP Virtual Server and am using DNS, however, Exchange BPA says "SMTP instance Default Virtual Server on <mailserver2k3> is configured to route all messages via smart host domain.com.outboundblablahlbah.  If I get more information, it says active directory was analyzed and the value msExchSmtpSmartHost has been configured.  Where is this attribute located so I can clear it?
0
 
LVL 6

Accepted Solution

by:
ilantz earned 400 total points
ID: 24325639
if you removed the smarthost on the smtp virtual server , then running BPA again will show that it's okay.
does mail flow from 2003 to 2007 works now ?

about the activesync authentication issue ,  just mark the Integrated Authentication in the Microsoft-Server-ActiveSync vdir in the 2003 iis. that should fix your issue.

please update with progress..
ilantz
0
 
LVL 1

Author Comment

by:ohmErnie
ID: 24325800
Ok...its working!!!  The smart host was configured in 2 places.  Under the routing group connectors and on the default SMTP Virtual server.  After I removed the smart host from the Default SMTP Virtual Server, mail began to flow.  I had previously removed it from just the Connector.
 
Also, public folder replication now works.
0
 
LVL 6

Expert Comment

by:ilantz
ID: 24325830
great !@ good job !
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question