Artifacts in Windows 7 RC

I just installed the Windows 7 RC and artifacts randomly appear.

I was thinking this could be a video card driver problem, but I did update the driver with the Windows 7 Beta version driver. I have the ATI Radeon 4830.
bappearlAsked:
Who is Participating?
 
tenaj-207Commented:
Here's a couple things to try.

Change the refresh rate;
1) right click on the desktop choose Personalize
2) Click the Display Settings link
3) Click the Advanced Settings button
4) Click on the Monitor  tab
5) Click on the drop down box under "Screen refresh rate" and drop the refresh rate down to the lowest number

If that fixes it, boost the refresh rate up one notch and retest, if it doesn't fix it then...

Check to see if it's a video card issue;
1) right click on the desktop choose Personalize
2) Click the Display Settings link
3) Click the Advanced Settings button
4) Click on the Troublshoot tab
5) Click on the Change settings button
6) Move the slider two notches to the left
7) Reboot and test

If that does fix the issue then you'll need a new video card.

If that doesn't fix it then...

If you have an onboard video card you can disable your PCIe video card in your BIOS and plug into your onboard card to see if the artifacts are still there.

Good luck!
0
 
bappearlAuthor Commented:
Here's a screen shot:
Artifacts.png
0
 
JBlondCommented:
Do you used the new driver released on 5 May?
http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/windows-7-64bit

0
 
bappearlAuthor Commented:
Yep, even though I just bought this video card last month, it seems it renders artifacts while processing 3D. I guess I'll send it in for a replacement.
0
 
bappearlAuthor Commented:
The video card is the problem. Thanks for the help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.