Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Unable to connect to Logical Disk Manager service

Posted on 2009-05-06
Last Modified: 2012-06-27
I click the disk management in computer management and get the 'Unable to connect to Logical Disk Manager service'.

I have looked around a lot and will describe what I have done and checked:
--Checked HKEY_LOCAL_MACHINE\Software\Classes\AppID to make sure 'Administrators' have access.
--Services status: DCOM Server Process Launcher=Started/Automatic
COM+ Event System=Started/Automatic
COM+ System Application=Started/Manual
Plug and Play=Started/Automatic
Remote Procedure Call (RPC)=Started/Automatic
Remote Procedure Call (RPC) Locator=Started/Manual

I have posted screen shots of the complete Services on the server.
Question by:fastrad
  • 5
  • 4
LVL 27

Expert Comment

by:Lukasz Chmielewski
ID: 24322983
start logical disk manager administrative service

Author Comment

ID: 24323017
Here are the results from starting logical disk manager admin service.  I tried this one already.  

Thank you for the response.  This is a strange error.  The only thing running on this computer is VMWare Server 2 and a RAID Utility program.
LVL 27

Expert Comment

by:Lukasz Chmielewski
ID: 24323112
have you seen this ? check for the image to see if your services match the ones there
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.


Author Comment

ID: 24323127
Yes, I have seen that one and that is when I checked both Logical Disk services and made them both automatic and restarted.  Then I moved to the Plug and Play and RPC services since those are dependencies. of so many services.
LVL 27

Expert Comment

by:Lukasz Chmielewski
ID: 24323139
try to boot into safe mode and see if the problem exists there

Author Comment

ID: 24323298
When I use Safe Mode I can access the disk manager

When I use Safe Mode with Networking I get the exact same error.

What network service can create a situation where the disk manager is either used/unavailable or disabled.  Could it be something with VMware Server?

Any ideas?

LVL 27

Expert Comment

by:Lukasz Chmielewski
ID: 24323317
did you try to turn off vmware server and access the disk management in normal mode / safe with networking ?

one more idea - try to update your NIC drivers.

Author Comment

ID: 24323605
I stopped services on the items shown on the screen shot.  It didn't help to resume connectivity to the Logical Disk Manager.  I updated the onboard Intel nic which is the only adapter in the machine and that didn't help connectivity to the Logical Disk Manager.  I even disabled the RAID utility.

That is where it stands.  Disk Management works in Safe mode only.

Since the services that needs to run is Logical Disk Manager for Disk Management are running (Plug and Play and RPC) and the dependencies of all services are running I am at a loss.

What else is there to check and troubleshoot?

LVL 27

Accepted Solution

Lukasz Chmielewski earned 250 total points
ID: 24323677
you mentioned that safe mode with networking - it does not work, how about disabling nic while in that mode and trying to check if the service can run ?
i'm trying to determine if that is not the nic card issue ...

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Windows File Server and SQL Auditor 3 33
Restricting Domain Admin Accounts 4 53
Reset Log Generation 3 22
How i can add "assistant" field to active directory General Tab 2 127
This article describes how to set permissions to allow a limited-permissions user to start and stop a particular System Service.   It is always best to give users only the permissions that they need to perform their job, so tweaking particular permi…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question