Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

ASA 5520 and ASA 5505 site to site VPN not working

Posted on 2009-05-06
4
Medium Priority
?
1,756 Views
Last Modified: 2012-06-27
Hello there,
 I need to connect two ASA as site to site VPN, cannot make it work. From the ASA5520 log, I see the phase 1 is complete, error message on both sides
713903 IP=66.x.x.187, Header invalid, missing SA payload! (next payload = 8)

Can you show me what is wrong? Thanks ahead.

the ASA 5520
 
ASA Version 7.0(7) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password lNUdmdZiTMKZb2Hn encrypted
names
dns-guard
!
interface GigabitEthernet0/0
 nameif inside
 security-level 100
 ip address 192.168.6.3 255.255.255.0 
!
interface GigabitEthernet0/1
 nameif outside
 security-level 0
 ip address 12.x.x.226 255.255.255.224 
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
 management-only
!
passwd YxeQWqXDjl9wZ7ho encrypted
ftp mode passive
access-list outside extended permit icmp any any echo 
access-list outside extended permit icmp any any echo-reply 
access-list outside extended permit tcp any host 12.x.x.228 eq smtp 
access-list outside extended permit tcp any host 12.x.x.229 eq https 
access-list outside extended permit tcp any host 12.x.x.227 eq https 
access-list outside extended permit tcp any host 12.x.x.230 eq https 
access-list inside_nat0_outbound extended permit ip any 192.168.6.192 255.255.255.248 
access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 10.0.10.0 255.255.255.0 
access-list s1 remark corp
access-list s1 standard permit 192.168.6.0 255.255.255.0 
access-list s1 standard permit 192.168.1.0 255.255.255.0 
access-list s1 standard permit 192.168.4.0 255.255.255.0 
access-list s1 standard permit 192.168.5.0 255.255.255.0 
access-list outside_cryptomap_20 extended permit ip 192.168.6.0 255.255.255.0 10.0.10.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu management 1500
ip local pool poolTemp 192.168.6.195-192.168.6.199 mask 255.255.255.0
no failover
monitor-interface inside
monitor-interface outside
monitor-interface management
asdm image disk0:/asdm-507.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 12.x.x.231-12.x.x.254
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 12.x.x.227 192.168.6.9 netmask 255.255.255.255 
static (inside,outside) 12..x.x.228 192.168.6.16 netmask 255.255.255.255 
static (inside,outside) 12..x.x.229 192.168.6.21 netmask 255.255.255.255 
static (inside,outside) 12..x.x.230 192.168.6.13 netmask 255.255.255.255 
access-group outside in interface outside
route inside 192.168.1.0 255.255.255.0 192.168.6.1 2
route inside 192.168.4.0 255.255.255.0 192.168.6.1 2
route inside 192.168.5.0 255.255.255.0 192.168.6.1 2
route inside 192.168.8.0 255.255.255.0 192.168.6.1 2
route outside 0.0.0.0 0.0.0.0 12.x.x.225 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server AAA1 protocol radius
aaa-server AAA1 host 192.168.6.4
 key xxxxx
group-policy corpRemote internal
group-policy corpRemote attributes
 dns-server value 192.168.6.4
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value s1
 default-domain value corp.org
 webvpn
username mm password dwlkvLt5fBDk7L5X encrypted privilege 0
username mm attributes
 vpn-group-policy corpRemote
 webvpn
http server enable
http 192.168.6.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 management
 
no snmp-server location
no snmp-server contact
snmp-server community ep1sc0p@l-ro
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 66.x.x.187 
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp nat-traversal  20
tunnel-group corpRemote type ipsec-ra
tunnel-group corpRemote general-attributes
 address-pool poolTemp
 authentication-server-group AAA1
 default-group-policy corpRemote
tunnel-group corpRemote ipsec-attributes
 pre-shared-key *
tunnel-group group1 type ipsec-l2l
tunnel-group group1 ipsec-attributes
 pre-shared-key *
telnet 192.168.6.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 50
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect http 
!
service-policy global_policy global
Cryptochecksum:e1d23511bac0d6b0144fb2d6a37d33fa
: end
 
 
ASA 5505
 
ASA Version 7.2(4) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.0.10.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.x.x.187 255.255.255.248 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list outside_1_cryptomap extended permit ip 10.0.10.0 255.255.255.0 192.168.6.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 10.0.10.0 255.255.255.0 192.168.6.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 66.x.x.1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 10.0.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 12.x.x.226 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.0.10.10-10.0.10.30 inside
!
 
tunnel-group 12.x.x.226 type ipsec-l2l
tunnel-group 12.x.x.226 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:7ae0fae33c7a698c3cc36320b0e33d32
: end

Open in new window

0
Comment
Question by:tomcattyy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 33

Accepted Solution

by:
MikeKane earned 2000 total points
ID: 24326311
From ASA 1 remove this line:
access-list inside_nat0_outbound extended permit ip any 192.168.6.192 255.255.255.248

On the 2nd ASA you have
crypto map outside_map 1 set pfs group1

But there is no pfs group set on the 1st ASA.   You must either remove PFS from the 2nd or addit to the 1st.     Bottom line is that the configs of the VPN tunnel must match on both sides.
0
 
LVL 1

Author Comment

by:tomcattyy
ID: 24328554
Hello Mike, I will try once I am in front of machine. the 2nd ASA is generated with wizard, can you explain what is the use of pfs? If that's not crucial then I will just remove it.
Thanks
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 24329427
PFS is Perfect Forward secrecy.   Its an additional layer of security for the uber-paranoid.   I never use it in my setups since my HQ connects to various different VPN endpoints, and it sometimes is an issue... plus it slows down the tunnel building process.  

http://supportwiki.cisco.com/ViewWiki/index.php/PFS




0
 
LVL 1

Author Comment

by:tomcattyy
ID: 24338014
Thanks Mike,
It's working now. remove the not used access list line.
remove the spf from the other site.
And the recreate the tunnel group with name as ip address.
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
Considering cloud tradeoffs and determining the right mix for your organization.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question