We help IT Professionals succeed at work.

BES Server won't sync Calendar items from BB device to Server - works fine other way

sebadlington
sebadlington asked
on
836 Views
Last Modified: 2012-06-27
Hi all,

this seems to be a common problem and I have been through as many posts as I can but still no joy.
If a user enters a calendar entry in outlook - it pops up on the BB device no problem, bu not the other way around.
we are runninng Win server 2003 SP2 with Bes Manager on same machine version 4.1.2.25

I have:
1. Check cdo.dll version and upgraded - it is now 6.5.7651.61
2. Checked BesAdmin permissions on the exchange server
3. resent service books a million times
4. checked wireless sync etc - I don't have an option in bb Manager for the calendar but assume it is tied to the mail?
5. rebooted the server etc

Not sure where to turn next, everything else works spot on, just the calendar causing grief

Thanks

Seb
Comment
Watch Question

Gary CutriEnterprise Mobility Engineer

Commented:

Author

Commented:
HThanks for that

Been working through the different solutions - still not running yet. I have an issue where the besadmin user is not being used to log on with the bb services, it was set to administrator - I changed it to the BESadmin but then got a stack of errors saying that the Messaging Agent could not be started and nothing would go through - I changed back to administrator and the messages started coming through again but still no calendar - I'm guessing this is because that user is a Domain Admin

Other thing, how do I check to see if the Public Folder Store has been mounted in Exchange?

Thanks
Gary CutriEnterprise Mobility Engineer

Commented:
Hi, first follow the 5 steps in my post below and ensure you run the dsacls command:

http://www.blackberryforums.com.au/forums/microsoft-exchange/1178-unlisted-message-error-desktop-email-program-unable-submit-message.html#post2071

Then ensure BESadmin is a local Administrator on the BES and when you check the Exchange Permissions ensure that all the mail stores are set to inherit permissions.
Gary CutriEnterprise Mobility Engineer

Commented:
Once this is done ensure that the BESadmin account is not a Domain Admin.

Author

Commented:
Followed the steps but having trouble with the dsacls bit
Getting "The specified domain either does not exist or could not be contacted"

Our domain is called DOMAIN - This is the script I ran (From a command prompt)
dsacls "cn=adminsdholder,cn=system,dc=domain,dc=com " /G "DOMAIN\BESadmin:CA;Send As"

Do I need to run the script somewhere else?

Thanks
Gary CutriEnterprise Mobility Engineer

Commented:
You have to run it from c:\Program Files\Support Tools and preferably whilst logged on as an Administrator.  Also confirm your domain name is correct e.g. dc=domain,dc=com  Vs dc=domain,dc=local

Author

Commented:
I will give this a try this evening and get back to you. Thanks, Seb

Author

Commented:
Nope - still not working
running the dsacls from where you said worked - got a long message saying successful
Did everything else as you said......I think. After lots of reeboots and changing user from Administrator to Besadmin which gives me this:

"BlackBerry Messaging Agent LOCKSVRMAIL01 Agent 1 failed to start. Error code 5302"

then back to administrator which does the same as before

still not got it working

Sorry maybe I'm misssing something...

Seb

Author

Commented:
Help - have followed the guide and the mapi profile was indeed miossing along with the registry keys - did the repair install and then have to re-enter all the configuration info again - now I have no users listed and it won't let me add the licences back in - keep getting:
"The license key being entered is not compatible with existing keys in the licence manager"

Aaaargh - needless to say, I am now very popular...not, with our 8 users.
Looks like we're getting somewhere though

Thanks

Author

Commented:
ok - managed to get the licences back in by deleting the trial one from the database - just waiting for the users to initialise - fingers crossed

Author

Commented:
Do i need to reactive these users from the handsets - as in the enterp[rise activation?

Author

Commented:
Help - seem to be totally stuck now - all the users are sat on intializing - nobodies pin has been picked up
Do i have to manually feed them in?
Enterprise Mobility Engineer
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Hi - server back up and on now eventually!

Author

Commented:
Thanks Gary for all your help
Mush appreciated - sorry to have disturbed your evening
Cheers
Seb
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.